I have connected a console to the line-in of my computer. How can I make it so that the sound comes out of the speakers?

I've tried alsamixer and it didnt help

Im using Ubuntu 12.04

  • computer / model / os version ? – Eliran Malka Nov 2 '12 at 21:21
  • Im using Ubuntu 12.04. Not sure about the other info. Would it help if I list my lspci? – Enrique Moreno Tent Nov 2 '12 at 22:10
  • which computer vendor is it (e.g. Dell / Asus / Toshiba)? and which model (e.g. Dell XPS / Asus ZenBook / Toshiba Satellite)? – Eliran Malka Nov 3 '12 at 13:58
  • Its a custom computer. The parts were chosen individually. – Enrique Moreno Tent Nov 4 '12 at 18:53

Try use the pulse audio: module-loopback, this module loops all incoming audio back through your outputs ,that isn’t enabled in Ubuntu by default.

#manualy start the module-loopback
pactl load-module module-loopback

#configure your system to load module-loopback on startup
#this places load-module module-loopback at the end of
#the /etc/pulse/default.pa pulseaudio configuration file.
sudo sh -c ' echo "load-module module-loopback" >>  /etc/pulse/default.pa '

This solution is copied from: http://thelinuxexperiment.com/guinea-pigs/jon-f/pulseaudio-monitoring-your-line-in-interface/

  • worked for me :), and the "couter-spell" to stop it again? – humanityANDpeace Mar 18 '13 at 5:28
  • 1
    the "counter-spell" is pactl unload-module module-loopback #and counter-spell to stop loading module-loopback on system startup is sudo sh -c 'sed -i "/load-module module-loopback/d" /etc/pulse/default.pa' – xranby Mar 18 '13 at 11:24
  • Thx, it seems so simple. I have in the meanwhile checked myself and it must be quite similar this pactl unload-module <ID of the modul> so the module name would not work in this case, which is counterintuitive... pactl list modules can yield the necessary <ID>. Thanks for responding. – humanityANDpeace Mar 19 '13 at 5:31
  • What is the incremented return value whenever the module is loaded? – Jackson Egan Feb 10 '16 at 2:12
  • hmm, I did this, and my audio out become from music to a weird buzzing with slowly decreasing pitch o.o – Neinstein Aug 7 '18 at 19:32

modification to xranby's answer:

I was having a problem with latency where there was quite a noticeable amount of lag between my button-press and the "immediate" sound.

This fixes that: pactl load-module module-loopback latency_msec=1

source of fix: http://thelinuxexperiment.com/fix-pulseaudio-loopback-delay/comment-page-1/#comment-2762


In the end I entered into "alsamixer" and rised the level of the Line-in, which was at 0 and it worked (in Ubuntu 10.13)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.