The package I am building on Precise instructs me to install OpenCV using synaptic to get libcv-dev libcvaux-dev and libhighgui-dev. So I opened up synaptic and checked the boxes and downloaded these packages.

Now I did a make and ended up with:

usr/bin/ld cannot find  -lcv
usr/bin/ld cannot find  -lcvaux
usr/bin/ld cannot find  -lhighgui

I Have tried downloading the non"-dev" OpenCV packages. No change. Downloaded OpenCV tarball, spent 45 minutes watching it cmake. make, make install. Same errors when I tried to compile my package.

I looked on an older Lucid machine where the package was built a couple of years ago. I compares the output of

locate libcv

with the new machine. The old machine shows libcv.so.4.0.0 etc and libcvaux.so...and libhighgui.so... The new machine shows no such things.

I'm willing to bet the new machine and new install may be later than the old ones, but they the lib files are completely missing.

Anyone know how to resolve this? Google has proven of not much use.

I am really concerned that the 12.04 install vers ion is so wildly different from the 10.04 versionb that I can't just compile my package.

My new build machine is a Dell R330 server adn all I get from goole is "don't even try a build older than 11.10. I opted for LTS so went with 12.04.


I had to download, make and install the opencv source code in a ubuntu 12.04 and it worked. I also tried to install the pre-compiled packages in my ubuntu 12.10 and got no problem.

Try this in a Terminal and tell me what you get:

sudo apt-get install libcv-dev libcvaux-dev libhighgui-dev

The opencv packages appear to have been renamed for oneiric. Try the libopencv-* equivalents instead.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.