Just installed Ubuntu 11.04. But it boots only from usb. Seems like I didn't pay attention during selecting boot device.

sudo fdisk -l
[sudo] password for klim:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x000177e1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       60045   482302976   83  Linux
/dev/sda2           60045       60802     6080513    5  Extended
Partition 2 does not start on physical sector boundary.
/dev/sda5           60045       60802     6080512   82  Linux swap / Solaris

Disk /dev/sdb: 4004 MB, 4004511744 bytes
124 heads, 62 sectors/track, 1017 cylinders
Units = cylinders of 7688 * 512 = 3936256 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000eee1a

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        1017     3909317    b  W95 FAT32

grub updating or another "grub" operations don't work as I've tried. Can I just copy whole boot folder from usb to HD or smth like that?

Any kind of help is appreciated. Apologize for my newbie skills.

  • Possible duplicate of: askubuntu.com/questions/125494/…
    – user68186
    Nov 2, 2012 at 18:10
  • What happens when you try to boot without the USB plugged in?
    – Aaron Hill
    Nov 2, 2012 at 18:49
  • User68186, thank you for response, but I've tried offered solutions, but they don't help.
    – klimat
    Nov 3, 2012 at 9:21
  • Aaron, it shows only "Operating System not found"
    – klimat
    Nov 3, 2012 at 9:22

1 Answer 1


I would strongly suggest that you just reinstall, being careful about where the installation goes to.

One quick check before doing that: Looking at that fdisk output, your first primary partition doesn't seem to be marked bootable. Run 'fdisk /dev/sda', type 'a'-Enter to start toggling a bootable flag, '1'-Enter to toggle the first partition's bootable flag. 'w'-Enter to write the partition table changes and exit.

If that doesn't fix things for you, then copying the boot folder (if there isn't one on your primary drive's Linux partition) to the primary drive's Linux partition would be the start of getting booting working off the hard disk. Then changes to /etc/grub.conf or /etc/default/grub would be required.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.