Previously I had Ubuntu 11.04 and I could boot with no monitor attached.

Now I have installed Ubuntu 12.10 with autologin and I've found that is incapable of booting correctly if the monitor isn't attached.

Is there a way to "force" Ubuntu to "remember" last monitor attached or to define a virtual one to allow a "normal" booting?


You need to do this :

go to directory :

cd /etc/X11/

cp xorg.conf xorg.bak

sudo gedit xorg.conf

Look for this section "Device" in the file, and update the file to be like this :

Section "Device"
     Identifier "Configured Device"
     Driver "vesa"

If you dont find this section then put it at the top of the file.

Try to keep the complete file consistent.

More Details step by step guide : Running Ubuntu without monitor

  • Thanks Vikash, my driver is already vesa, and it isn't working. Here is my xorg.conf: Section "Device" Identifier "Configured Video Device" Driver "vesa" Option "NoDDCValue" "True" EndSection Section "Monitor" Identifier "Configured Monitor" HorizSync 31.5-48.5 VertRefresh 50-70 EndSection Section "Screen" Identifier "Default Screen" Monitor "Configured Monitor" Device "Configured Video Device" DefaultDepth 24 SubSection "Display" Depth 24 Modes "1024x768" EndSubSection EndSection – john Nov 2 '12 at 17:20
  • Try and change the < Identifier "Card0" > and see if it works... – Vikash Singh Nov 2 '12 at 18:02
  • Nope, and sorry about the raw xorg.conf I couldn't figure it how to format it properly. – john Nov 2 '12 at 18:28
  • Anyone know why this feature is broken from previous versions? Is this a bug? – john Nov 2 '12 at 19:41

protected by Community Nov 6 '12 at 21:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.