Failing at installing/removing any packages or codecs, plugin installation fails too.

An unhandlable error occured

There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks.


org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/lib/dbus-1.0/dbus-daemon-launch-helper received signal 6

while trying various commands through terminal I get these details at the end and info that dpkg has errors processing these...

Errors were encountered while processing:

the following error also shows up in the terminal

Fatal Python error: Py_Initialize: Unable to get the locale encoding
EOFError: EOF read where not expected
Aborted (core dumped)

What should I do?


I just spent my morning recovering from just such a problem -- My battery in my laptop died while in the process of an update (yeah I know I'm an idiot! O_o)... I was getting the same error message:

Fatal Python error: Py_Initialize: Unable to get the locale encoding
EOFError: EOF read where not expected
Aborted (core dumped)

The way I fixed it is first:

sudo dpkg -P --force-all python3.2-minimal

sudo apt-get -f install

Which will re-install python3.2-minimal, but will still have errors from other packages -- a summary of errors will be shown at the end such as:

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

After that, simply take the list one-by-one:

sudo dpkg -P --force-all <package>

sudo apt-get -f install

Once you've purged and re-installed all packages with errors, the system should be back to normal and you can do a

sudo apt-get update && sudo apt-get upgrade

Just to be sure everything is updated properly.

Hope that'll help someone in the future. :-)


Looks like a incomplete install. Did something happen during the install process? Have you tried apt-get update && apt-get upgrade to make sure you don't have stale packages running around.

Your error seems to be with python, which a lot of the system uses. You could try

sudo apt-get remove python3.2 --simulate

To see what APT will do if you remove it. But that could break a great many things.

Basically, either your python install is hosed, or your PYTHON environment variable is really goofed up.

  • Before you go too deep, exit software center and try the good ol' apt-get -f install to see if you have an incomplete install of anything. – coteyr Nov 2 '12 at 14:02
  • well duriong the upgrade from 10.04 to 12.10 there was a power outage.. then i had to download 12.10 again and installed it from a flash drive (this time it looked clean) but there might be an error from there apt-get update && apt-get upgrade does not work...same issues turn up as mentioned before....EOF and packages etc.. i took a risk and removed python 3.2..... and it does seem that a great many things are broken now... so now i need to know how to put it back because anything i do ends up with a list of packages which couldn’t be processed (as said before) – Prakhar Gupta Nov 2 '12 at 14:37
  • Are you getting the exact same error? Run python from the command line, if that works "import system" and see if that works. Your not really trying to do anything just to get a list of things that might be stopping python from loading. – coteyr Nov 2 '12 at 17:05
  • Also it looks like python is conflicting between a "system" version and a installed by something else version. Did you install python by hand at some point before the upgrade? Did you format the drive when installing 12.04? – coteyr Nov 2 '12 at 17:08
  • thank you for your advice but i believe im too much of a noob to set this right now, ive probably made it worse only as the list of conflicting packages has gotten longer after messing with python...and im not really comfortable with 12.10 so i think i'll just download 10.04 now and revert back to it...hopefully that goes fine...thank you once again for your help – Prakhar Gupta Nov 2 '12 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.