3

I mounted my nas in ubuntu 12.10 and it works with read/write, but when I'm adding a file or directory that file gets read only permissions. My fstab mount looks like this:

//192.168.0.12/share/ /media/nas cifs credentials=/home/jocke/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

If I mount the smb share manualy through the GUI it works, but not through fstab.

What I am doing wrong?

4

Solved the problem! I added the noperm option to the fstab mount. So now it looks like this:

//192.168.0.12/share/ /media/nas cifs credentials=/home/jocke/.smbcredentials,noperm,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
  • 2
    What does the noperm parameter do? – Gabriel Fair Feb 26 '18 at 20:38
  • Found it, in the docs: Client does not do permission checks. This can expose files on this mount to access by other users on the local client system. It is typically only needed when the server supports the CIFS Unix Extensions but the UIDs/GIDs on the client and server system do not match closely enough to allow access by the user doing the mount. – danger89 Oct 8 '18 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.