I'm using fluxbox. I've noticed that the TTF fonts are quite blurry (particularly in GVim):

Here's an example, using Inconsolata 12pt in Fluxbox:

enter image description here

Here's the same example, using Inconsolata 12pt, except in Unity:

enter image description here

You can see that not only is the text easier to read in the Unity case, it's also larger. The font colors look faded in the fluxbox case as well. What I would like to ask is:

  1. How can I make the font under Fluxbox look the same as under Unity? It looks as if Fluxbox isn't getting the font sizes quite right and doing excessive antialiasing.
  2. Why are the fonts being rendered at different sizes? I thought 12pt should look the same in every environment (on the same hardware).

I'm using an LCD, so my font settings under gnome-tweak-tool are:

  • Hinting: slight
  • Antialiasing: RGBA

Here are my DPI settings (same under Fluxbox and Unity):

misha@misha-lmd:~$ xdpyinfo | grep -B2 resolution
screen #0:
  dimensions:    1280x1024 pixels (382x302 millimeters)
  resolution:    85x86 dots per inch


Problem solved after editing .Xresources. Before:

enter image description here


enter image description here

2 Answers 2


This looks like a different handling of font hinting/aliasing from Fluxbox vs. GNOME/Unity.

Warning: The following is for experiences users only!

According to the Fluxbox Wiki (untested as we do not run Fluxbox here) we can define font settings by creating a ~/.Xresources file in our HOME where font rendering can be defined with the following entries (amongst many others):

 Xft.antialias:                 true
 Xft.hinting:                   true
 Xft.hintstyle:                 hintfull
 Xft.rgba:                      rgb

To take effect we run

xrdb ~/.Xresources

Disclaimer: we have no own experience whether an additinoal .Xresources file also affects our GNOME/Unity XServer settings. Therefore do apply these settings with care. Update any pre-existing settings before you change anything as wrong X-server settings may render your X-display unusuable.

  • The Unity fonts still look larger by 1pt size for some reason, but the blurriness is gone. It looks much better now. Thank you!
    – mpenkov
    Nov 2, 2012 at 8:34

It seems that gnome terminal (I suposse thats what you're using) has some font configuration in preferences that adds shades, because thats the only difference I can tell from the pictures.

  • Those are GUI apps. I'm not using a terminal.
    – mpenkov
    Nov 2, 2012 at 7:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .