I have just installed conky on my ubuntu 12.04 LTS but it appears... in the terminal ( and only in it ):

$ conky

Uptime: 0h 3m 35s
Frequency (in MHz): 800
Frequency (in GHz): 0.80
RAM Usage: 740MiB/3.76GiB - 19% ##________
Swap Usage: 0B/3.72GiB - 0% __________
CPU Usage: 6% #_________
Processes: 146  Running: 1
File systems:
 / 14.1GiB/91.7GiB ##________
Up: 0B  - Down: 0B
Name              PID   CPU%   MEM%
 conky             2445   0.00   0.03
 bash              2390   0.00   0.12
 gnome-pty-helpe   2389   0.00   0.02
 gnome-terminal    2383   0.00   0.52

I have tryed other conkyrc files to customize it but I get somethings like this:

$ conky -C /home/ubu/Scrivania/conky_grey/conkyrc_grey 
# Conky, a system monitor, based on torsmo
# Any original torsmo code is licensed under the BSD license
# All code written since the fork of torsmo is licensed under the GPL
# Please see COPYING for details
# Copyright (c) 2004, Hannu Saransaari and Lauri Hakkarainen
# Copyright (c) 2005-2010 Brenden Matthews, Philip Kovacs, et. al. (see AUTHORS)
# All rights reserved.
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# GNU General Public License for more details.
# You should have received a copy of the GNU General Public License
# along with this program.  If not, see <http://www.gnu.org/licenses/>.

background no
cpu_avg_samples 2
net_avg_samples 2
no_buffers yes
out_to_stderr no
update_interval 1.0
uppercase no
use_spacer none

${scroll 16 $nodename - $sysname $kernel on $machine | }
Uptime: $uptime
Frequency (in MHz): $freq
Frequency (in GHz): $freq_g
RAM Usage: $mem/$memmax - $memperc% ${membar 4}
Swap Usage: $swap/$swapmax - $swapperc% ${swapbar 4}
CPU Usage: $cpu% ${cpubar 4}
Processes: $processes  Running: $running_processes
File systems:
 / ${fs_used /}/${fs_size /} ${fs_bar 6 /}
Up: ${upspeed eth0}  - Down: ${downspeed eth0}
Name              PID   CPU%   MEM%
 ${top name 1} ${top pid 1} ${top cpu 1} ${top mem 1}
 ${top name 2} ${top pid 2} ${top cpu 2} ${top mem 2}
 ${top name 3} ${top pid 3} ${top cpu 3} ${top mem 3}
 ${top name 4} ${top pid 4} ${top cpu 4} ${top mem 4}
  • Try setting the "own_window_type" variable to normal. It works for me. – Jonas B Mar 9 '14 at 10:14

Weird, try this conkyrc file. This one works for me. Does it work for you as well? If it does, perhaps you can try to adapt it to your own needs.


  • I have just tryed your conkyrc file, but also in this case it appears only in the terminal :( – xRobot Nov 1 '12 at 18:14
  • Darn. This sure is a weird error. How did you install conky? apt-get? – Malcolm Nov 1 '12 at 18:58
  • I have installed it with Ubuntu Software Center – xRobot Nov 1 '12 at 20:25
  • This feels like a shot in the dark, but perhaps you should try removing it thru the software center, then installing it through apt-get on the command line (apt-get install conky). There's a few packages: $ apt-cache search conky conky - highly configurable system monitor (transitional package) conky-all - highly configurable system monitor (all features enabled) conky-cli - highly configurable system monitor (basic version) conky-std - highly configurable system monitor (default version) Try the conky-all one first. – Malcolm Nov 1 '12 at 21:56

You can remove it and all config files by typing this command:

sudo apt-get --purge remove package name

and install back using this command

sudo apt-get install conky-all

After that, run back your conky.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.