I have a freshly setup 12.04 LTS pc system (120 GB SSD, 1 TB HDD, 16 GiB RAM); since a few days, I can't login to the graphical desktop anymore: there is very short flashing shell window which disappears very quickly (edit: see below), and I'm confronted with the login screen again. I believe there is something about modprobe and vbox, but I can't read it fast enough ...

I can login to a terminal (Ctrl+Alt+F1). It did not help to chown all contents of my home directory to me:my-group, like suggested here.

This is what I could find in /var/log, grepping for the date and time (I inserted linebreaks after <my-hostname>; real time values preserved):


<date> 22:43:01 <my-hostname>
    lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "tobias"
<date> 22:43:08 <my-hostname>
    lightdm: pam_unix(lightdm:session): session closed for user lightdm
<date> 22:43:08 <my-hostname>
    lightdm: pam_unix(lightdm:session): session opened for user tobias by (uid=0)
<date> 22:43:08 <my-hostname>
    lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0
<date> 22:43:08 <my-hostname>
    lightdm: pam_unix(lightdm:session): session closed for user tobias
<date> 22:43:09 <my-hostname>
    lightdm: pam_unix(lightdm:session): session opened for user lightdm by (uid=0)
<date> 22:43:09 <my-hostname>
    lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0
<date> 22:43:10 <my-hostname>
    lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "tobias"
<date> 22:43:10 <my-hostname>
    dbus[756]: [system] Rejected send message, 2 matched rules; type="method_call", sender="1:43" (uid=104 pid=1639 comm="/usr/lib/indicator-datetime/indicator-datetime-ser") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1005 comm="/usr/sbin/console-kit-daemon --no-daemon ")


<date> 22:43:00 <my-hostname>
    kernel: [   16.084525] eth0: no IPv6 routers present


<date> 22:43:00 <my-hostname>
    kernel: [   16.084525] eth0: no IPv6 routers present
<date> 22:43:01 <my-hostname>
    ntpdate[1492]: adjust time server offset -0.162831 sec
<date> 22:43:08 <my-hostname>
    acpid: client 969[0:0] has disconnected
<date> 22:43:08 <my-hostname>
    acpid: client connected from 1553[0:0]
<date> 22:43:08 <my-hostname>
    acpid: 1 client rule loaded

I have Virtualbox and Truecrypt installed, but I can't think of a reason why they might prevent a graphical login.

I'm confused:

  • What is this about requirement "user ingroup nopasswdlogin" not met? I do login using a password, and the password works ok when logging in to a terminal!
  • Can I somehow read the error output, e.g. by delaying it, redirecting it to a file, or having the system prompt me for pressing a key?
  • Has possibly any recent update caused my problem? Should I install the pending updates? How, btw, without access to the graphical UI?

I have some working knowledge about the Linux shell, but I'm new to Ubuntu. Any help would be appreciated.

Edit: After shutting down the machine yesterday (sudo shutdown now), I found the following text on the screen, which appears to be the "flashing" text mentioned before (formatted; there was some silly leading whitespace):

Could not write bytes: broken pipe
speech-dispatcher disabled; edit /etc/default/speed-dispatcher
* Starting VirtualBox kernel modules
* modprobe vboxdrv failed. Please use 'dmesg' to find out why
saned disabled; edit /etc/default/saned
* Checking battery state... [ OK ]

After manually copying it, I switched the machine off by pressing the button several seconds.

Might be that virtualbox (4.2 installed) causes the problem. I'll add some more log file extractions later today (MET).

Edit, for the records: I tried the following, from /a/133754/103086:

  • sudo apg-get install gdm (when prompted, chose GDM)
  • rebooted; login failed with GDM, too
  • sudo dpkg-reconfigure lightdm, rebooted; login won't work
  • my ~/.Xauthority file is empty; deleting it and rebooting didn't change anything


  • deinstalled virtualbox (sudo apt-get remove virtualbox-4.2), rebooting

Edit: I uploaded a zip archive of selected/filtered log files to http://www.tobias-herp.de/en/errors/ubuntu-gui-lockout. Kept apt-get upgradeing recently, but unfortunately the problem persists.

  • I have a script to extract log lines now (and copy files with non-prefixed lines), and I'd upload a zip archive (since it would be 1619 lines in 6 files, including 924 lines in dmesg), but I can't find out how to upload it ... – Tobias Nov 3 '12 at 14:47
  • Could this tweek-it-up.blogspot.com/2012/08/… be it? – arielf Nov 6 '12 at 7:32
  • Nope; the ~/.Xauthority file is completeliy "mine" (tobias:tobias). – Tobias Nov 9 '12 at 9:44
  • I recently setup a new 12.04 desktop (already have 5 others) and the new one was running into problems login into the GUI with ldap users, but not local. I struggled with it with limited success, then gave up and installed Mint which worked. I'm guessing there is some kind of regression in a recent update. rant: ubuntu is becoming a complete mess. just look at the crazy pam setup with configuration tools that are even more complicated and arcane than manual pam configuration. – Cyclone Feb 4 '14 at 17:42
  • OP reinstalled the system – Braiam Mar 20 '14 at 23:05

Removing ~/.Xauthority worked for me

  • Same here, even if the ~/.Xauthority was with right permission and right owner (me). – vaab Sep 23 '13 at 16:42
  • Likewise this worked for me (on Ubuntu 13.04) – Stabledog Oct 6 '13 at 10:01
  • Yes, removing the file is necessary because the data in the .Xauthority file will differ (perhaps there is a pid or date context?). Permission alone is not the usual problem. – Andrew Jun 22 '16 at 1:46

I had this same issue. It turned out that my problem was that ~/.Xauthority was updated as root, and from then on only root could read it. It stopped me from starting any X session from my username. I had to sudo rm ./.Xauthority and it worked fine after that.


I finally gave up and reinstalled the system. This was not a problem, since the system was quite fresh, and most personal data was not yet migrated to it. I can't tell for sure the problem was not caused by a non-standard package, so ...

So I started anew, and I took precautions to be better off next time. After installation, I updated the system, installed some crucial packages and pinned an eye to the configuration:

sudo bash
apt-get upgrade
apt-get install ssh mercurial vim
cd /etc/
vim mercurial/hgrc
hg init .
hg add *
hg commit

Thus, whenever a new problem occurs, I should stand a better chance to know what might have gone wrong.

  • Just for the records: after a while, even the newly setup system run into the same problem. I decided to remove Ubuntu totally and installed Windows instead (with a virtual Linux machine). – Tobias May 28 '13 at 14:23
  • Just for the records: what you do with "hg" is done automatically thanks to the package "etckeeper" (and you can choose mercurial, bazaar, git...) – vaab Sep 23 '13 at 16:38

In my case, this was caused by a wrong ~/.dmrc as explained here. This can be detected thanks to ~/.xsession-errors where I had the following error:

x-terminal-emulator: Fatal IO error: client killed konsole(1598) Konsole::SessionManager::~SessionManager: Konsole SessionManager destroyed with sessions still alive

  • 2
    worked for me too. Kubuntu 12.04, KDE. I deleted both .dmrc and.Xauthority. Thanks! – MountainX Sep 26 '13 at 3:47

A similar problem happened to me after I added an export PATH=$PATH:/home/<user>/SomeFolder to the end of /etc/profile. After I logged into a terminal, removed that line and rebooted, I could login normally and the problem seems to have gone away.


  • I was getting the following flashing text on the screen before the login screen:

    Could not write bytes: broken pipe
    * Starting VirtualBox kernel modules
    saned disabled; edit /etc/default/saned
  • Ubuntu 12.04 LTS, 64-bit, Intel Core i5, 6GB.
  • I have VirtualBox 4.2.18 installed but it seems to be working just fine.
  • I dual boot with Windows 8 using GRUB.
  • Could this have been the problem? I don't know. I usually have a ~/bin directory which I like to have in the PATH, but the installation doesn't exist anymore. – Tobias Sep 19 '13 at 8:09
  • You pushed me into the right direction when solving the problem which appeared on my netbook as well, which still has Ubuntu. One of the shellscripts I sourced automatically during login caused an error, and there as a line in ~/.xsession-errors; when I tried it in a shell, all looked ok. However, I disabled loading the scripts, and I can login graphically again. – Tobias Sep 28 '13 at 13:31

Running into this now using lightdm + any non unity greeter. If I set the greeter to unity-greeter in /etc/lightdm/lightdm.conf, it seems to work. No idea why.

Edit: redacted. Something I just pulled in with an update must have caused this and now even the unity greeter doesn't work.

  • 1
    I had a look at this file; in (the one and only) section SeatDefaults, the value of the greeter-session is unity-greeter already. Any other value I could try? – Tobias Nov 9 '12 at 19:14

In my case I added some commands into .xprofile which caused the return back to login-screen right after login. The errors I found were the same. Remove everything non-essential from your ~/.profile and ~/.xprofile should bring the situation back to normal.


For me this happened when there is some invalid path entry make in .profile file. When I removed it, it worked perfectly. Check your .xsession-error file for the error it reports


There was the same error for me on Ubuntu 14.04.02 LTS. I have opened log file /var/log/lightdm/lightdm.log and see message like ...not enough disk space for .Xauthroity.... Then I have found that there is really zero space on disk. So I have removed some files and bug disappeared.

protected by Braiam Mar 20 '14 at 23:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.