4

I am a Ubuntu user since years and I have not come across this problem till date.

My battery drains off immediately after I unplug my AC power.

The options I tried:

1) I checked the battery state with : cat /proc/acpi/battery/BAT0/state

present:                 yes
capacity state:          ok
charging state:          charged
present rate:            0 mA
remaining capacity:      392 mAh
present voltage:         12476 mV

Initially it was showing charging state: charging after 5 minutes it started displaying as charged! Based on that, if i remove my AC Power it shows low battery notification.

2) When I run acpi : acpi -b

Battery 0: Unknown, 9%

The battery state shows as unknown. But initially when we plug-in to AC adapter

acpi -b
Battery 0: Charging, 9%, 13:04:00 until charged

3) When I check the same with : upower -i /org/freedesktop/UPower/devices/battery_BAT0

  native-path:          /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:02/PNP0C09:00/PNP0C0A:00/power_supply/BAT0
  vendor:               HP
  power supply:         yes
  updated:              Thu Nov  1 16:06:40 2012 (20 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               charging
    energy:              4.2336 Wh
    energy-empty:        0 Wh
    energy-full:         33.1128 Wh
    energy-full-design:  33.1128 Wh
    energy-rate:         5.6052 W
    voltage:             12.474 V
    time to full:        5.2 hours
    percentage:          12.7854%
    capacity:            100%
    technology:          lithium-ion

In the power stats output, It says 5 hours to charge completely, yet if I charge it even more than 5 hours and unplug the AC power, it cribs again stating LOW BATTERY !!

The same thing does not happen with Windows 7.

Any suggestions/help will be greatly appreciated.

4
  • 2
    The kernel version which I am using : uname -a; cat /etc/lsb-release Linux shyam-Laptop 3.2.0-31-generic #50-Ubuntu SMP Fri Sep 7 16:16:45 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux DISTRIB_ID=Ubuntu DISTRIB_RELEASE=12.04 DISTRIB_CODENAME=precise DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS"
    – Shyam
    Nov 1, 2012 at 11:03
  • You should be able to edit your question through the edit link at the end and add this information directly to the post.
    – user98085
    Nov 1, 2012 at 15:39
  • 392 mAh reminaing capacity is the real capacity of the battery or is it new? If not it´s telling you that the battery life has ended although, below when I read the capacity 100% I get a little bit confused because I don´t know if it is the real capacity of the battery untill the date or it is the capacity it had when it was new.
    – Brask
    Jan 8, 2014 at 0:01
  • I hope it is not damaged but it seems that the battery has not been used and that it has stopped working correctly and must be calibrated again via BIOS.
    – Brask
    Jan 8, 2014 at 0:01

2 Answers 2

1

It could be many things causing the battery to drain, the first cause being the screen.

I'll try to help you, follow my steps.

Plug your laptop's AC power to begin with.

Open the terminal and run:

sudo apt-get install xbacklight.

After you installed it run this other command:

xbacklight -set 10

If you have bluetooth and don't use it turn it off.

If you're not using WiFi turn it off too.

sudo iwconfig wlan0 txpower off 

and

sudo iwconfig wlan0 txpower on

to turn it back on.

To make the processor drain less battery you can use the power saving feature:

echo 1 > /sys/devices/system/cpu/sched_mc_power_savings

Now, the hard disk spinning isn't energy-free so you could tune it to spin only when necessary. Run this to install Hdparm:

sudo apt-get install hdparm

then run this command:

hdparm -i /dev/sda

if you see AdvancedPM=yes in there go on and run this other command to enable power saving for the hard disk:

hdparm -B 1 -S 12 /dev/sda

Finally let the battery fully charge, reboot, then unplug the AC power cable and see if the battery consumption changes.

0

392 mAh is probably not enough to power up.

It is quite possible you need a new battery. Try charging it overnight. If the battery does not go much above 392 mAh, it is most likely the battery needs replacing.

However, you could try unplugging the machine, then remove the battery...wait for 2 minutes, re install the battery and try again.

If that fails, you need a new battery.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.