This problem is on two of my computers, both running Gnome-Classic on 12.10, my laptop and my desktop.

After recent reboots, the app indicator area has text that says "No Indicators":

no indicators

Indicators for battery state, Dropbox, Spideroak, Jupiter, and various other things are not appearing. Not having the battery indicator is especially troublesome because I can't know how long my laptop will be able to work.

This happens on all user accounts.

I tried to reinstall Gnome Desktop as advised in this answer, but it did not help.

I've tried to reset Gnome to default settings following the advice in this question, but unfortunately, while it did reset most of Gnome such as my desktop wallpaper and Compiz settings, it did not change the indicator problem in any way.

How do I get my indicators back and working properly?

  • If you have reinstalled the Gnome Desktop, it must be a configuration problem. Do you know, now, where is the configuration saved?. Originally all global configurations were all in /etc but now who knows.... Has your problem worsen after following those advises? or it is exactly the same? Nov 10, 2012 at 0:48

2 Answers 2


This was solved by re-installing Unity.

Although I don't use Unity, I use Gnome-Classic, I guess there are packages necessary for the indicator applet that are somehow bound to the Unity set of packages.

Hopefully at some point This kind of thing will be unbound from Unity so that one doesn't need any Unity packages in order to run Gnome-Classic.

  • As a reference, to reinstall Unity run sudo apt install unity. I know it's trivial, but it might help someone.
    – gionni
    Apr 30, 2020 at 7:56
  • I use the MATE desktop and I have the same problem, but reinstalling unity was not an option... it was never uninstalled. Sep 6 at 7:43

Maybe this one helps: Volume and other indicators disappeared in the classic desktop

This guy has a similar problem. Check the last answer. In a nutshell, he suggests using dconf-tools to re-enable applets.

  • Unfortunately I can't find anything related to appmenu in dconf-editor, and I have attempted to install all app indicators available in the ubuntu repository.
    – Questioner
    Nov 3, 2012 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.