My problem is I've 4 disks in a raid array listed as sda, sdb... sdd and grub 2 refuses to boot on /sde (the 5th disk, standalone and containing a clean install of 12.04 LTS).

I tried all solutions but all fail. (live CD/USB with grub-setup, also tried repair-grub, and tried also in the "grub rescue" set prefix= etc - no disks appear).

I also tried to deactivate the RAID array in the BIOS, but I'd rather not destroy it, and I didn't find a way to [reorder] make the standalone disk as '/sda1' (this would satisfy grub). In the BIOS, the would-be /sda is the only bootable hard disk; it ends up as /sde and grubs complains.

I've made repair-grub issue a pastebin.

I always end up in grub-rescue and I'm stuck. I need Ubuntu to boot so that I can add the device array handler for my disks. I can't switch the disks and I can't disconnect the SATA RAID controller.

I need: (a) a workaround so that grub starts on /sde; or (b) a way to change the order in which Ubuntu sees the disks, at boot time. I could then provide grub with a /sda1.

Thanks a lot.

--- addendum

it's not the same problem as booting ubuntu from raid. My RAID array serves only of data repository

windows had no problem with this configuration

--- addendum up

2 months after, I'm now still stuck. No Grub/Ubuntu guru around ?

The data clearly show that only /sde has GRUB installed. Nevertheless, GRUB is unable to boot as soon as the RAID array (/sda../sdd) is mounted.

I waited two months in hope a patch would fix GRUB in such a situation, but nothing comes up and I'm fed up being cut from my RAID array.

My only option left is to reinstall Windows for my server... at least it's able to boot while I have my data connected in its RAID array...

It's a shame : my everyday computer would be on Ubuntu and my server would have Windows...


  • as you can see from the pastebin, /dev/sde1 is the only bootable partition, and sde1 is the only one containing a boot loader. So the problem is PURELY GRUB related. The RAID array is NOT bootable and never has been. Its simple PRESENCE perturbates GRUB/Ubuntu loading. As you may see also, Grubrerpair saw the grub files which grub can't find at boot time and doesn't find in the "grub rescue" prompt. Please advise... 3 Months now... ______________ File system: ext4 Operating System: Ubuntu 12.04 LTS Boot files: /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img – VGR Nov 6 '12 at 7:22

There should be a hdd=(4,0) option in grub line that should work. This means boot from sde1 (5th disk, first partition). Notation might be off as this is from memory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.