As already pointed out here, people seems to have issues with installing wine in the latest version of Ubuntu. I'm suspecting this only happens with 64 bit users.

For example, when trying to install wine or ia32-libs with apt-get, I get a lot of dependency errors. Doing a sudo apt-get -f install doesn't seem to do the trick, neither does using aptitude.

The errors I get is normally that the packages depend on some :i386 package, but installing those manually doesn't work either because they also have dependency issues (isn't APT supposed to do this automatically?!). I also downloaded CrossOver today and tried installing the .deb manually, but the dependency issues show up there as well. When running sudo apt-get -f install after trying to install the CrossOver .deb, apt-get wants to purge the following packages:

  • ia32-crossover
  • intel-gpu-tools
  • libdrm-nouveau2
  • libgl1-mesa-dri
  • libva-x11-1
  • ubuntu-desktop
  • vlc
  • xorg
  • xserver-xorg-video-ati
  • xserver-xorg-video-intel
  • xserver-xorg-video-modesetting
  • xserver-xorg-video-openchrome
  • xserver-xorg-video-radeon
  • xserver-xorg-video-vmware

What I've tried so far (and didn't work):

  • Installing synaptic, reloading my repositories, searching for ia32 and installing ia32-libs.
  • Using Ubuntu Software Center to install Wine and ia32-libs.
  • Using apt-get and aptitude to install all the differend varieties of the wine packages, both with and without the :i386 and -amd64 suffixes in package names.
  • Disabling the universe and multiverse repos, run a sudo apt-get update and then re-enable them again.
  • Boot a newly downloaded Ubuntu 12.10 x64 live USB and try to install all the different packages there.

What I've tried so far (that actually DID work):

  • Installing 12.10 x64 in VirtualBox and installing wine1.4-amd64.

What I haven't tried (yet):

  • Boot a newly downloaded Ubuntu 12.10 x32 image and try to install wine there (I'm just guessing that will work).
  • Reinstall Ubuntu.
  • Throw my computer out a window.


alexander@cosmo:~$ LANGUAGE=en_US sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


alexander@cosmo:~$ sudo apt-get install wine1.4
The following packages have unmet dependencies:
 wine1.4 : Depends: wine1.4-i386 (= 1.4.1-0ubuntu1)
E: Unable to correct problems, you have held broken packages.


alexander@cosmo:~$ sudo apt-get install ia32-libs
The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
E: Unable to correct problems, you have held broken packages.
  • Try installing ia32-libs-multiarch.
    – green
    Oct 31, 2012 at 12:39
  • @green7 I should have mentioned that installing ia32-libs-multiarch doesn't work either.
    – carestad
    Oct 31, 2012 at 13:49

7 Answers 7


Okay. So I found out what caused my problems. It was probably some PPAs with certain packages that created the dependency issues. While surfing randomly at Askubuntu last night, I came across an answer that fixed my problem.

Here is the answer, just modified so it works for Ubuntu 12.10:

First a downgrade is required and done with the following: create the 'preferences' file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=quantal*
Pin-Priority: 2012

enter :wq to write the file. Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

And that was it. Installing wine, crossover and ia32-libs now work. Why this happened when I ran a freshly downloaded 12.10 version of Ubuntu live I don't know and don't understand.

Thank you all for trying to help!


This drove me crazy as well. I installed Ubuntu 64-bit using plain debootstrap from a 32-bit Ubuntu lucid (booting a newer 64-bit kernel).

After digging through forums and documentation I found out that I had to do:

dpkg --add-architecture i386

(actually I found a page on disabling multiarch and figured out that it was not enabled in the first place)

  • this did not help me. Nov 11, 2012 at 1:41
  • 1
    apt-get update after that and it worked! I had done the same: Installed Ubuntu 64bit via debootstrap.
    – Albert
    May 25, 2013 at 12:17

I'm also using Ubuntu 12.10(64-bit), and I had installed both Wine and ia32-libs package without any problem.So this is not the problem of having 64-bit. You should try to install both "wine 1.4.1" and "Ia32 shared libraries - transitional package" through Ubuntu Software Center, like I did.

  • installing wine with the terminal(sudo apt-get install wine) worked fine for me. And quite right, it seems he is missing that Ia32 package.
    – Dr_Bunsen
    Oct 31, 2012 at 13:01
  • @Dr_Bunsen doesn't work here. Maybe my entire software catalog is broken somehow. If that's the case, I wouldn't know how to fix it :-S
    – carestad
    Oct 31, 2012 at 13:51
  • @carestad use ubuntu software center as I said above Oct 31, 2012 at 13:55
  • @KashmirHackers yes, I did, but that didn't help.
    – carestad
    Oct 31, 2012 at 13:59
  • @carestad use sudo apt-get update -f, what do you get?
    – Dr_Bunsen
    Oct 31, 2012 at 14:03

It seems you have multiple repositories in your APT sources list that contain wine packages. Combined with suboptimal APT preferences (defaults defined in /etc/apt/preferences) this can lead to installability problems. To fix these it might suffice to do the following.

sudo apt-get -t quantal install wine1.4

If this does not suffice then temporarily remove from your sources list references to alternative wine repositories. You may, for example, have a file /etc/apt/sources.list.d/ubuntu-wine-ppa-quantal.list whose contents look like the following.

deb     http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu quantal main
deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu quantal main

Comment these lines out and try again to install the wine1.4 package.

  • that didn't work either. I just booted (two minutes ago) a freshly downloaded live image of Ubuntu 12.10 x64 and still no action. I got exactly the same dependency issues there (after enabling the universe and multiverse repos of course).
    – carestad
    Oct 31, 2012 at 15:11
  • Update: I just ran fresh install in VirtualBox of 12.10 x64, and there it actually worked, which leads me to believe that this could have something to do with my hardware setup and what drivers (xorg drivers?) are installed on my computer. VirtualBox use very generic hardware so it's possible this just affects people with certain hardware.
    – carestad
    Oct 31, 2012 at 17:48
  • Is it possible that the machine referred to in your original question has third-party packages installed (e.g., from your attempt to install CrossOver) that are incompatible with the wine packages that you now want to install?
    – jdthood
    Oct 31, 2012 at 19:13
  • It's possible. I use some PPA's, but shouldn't that be eliminated when I booted the same computer through a live USB and tried installing Wine there?
    – carestad
    Oct 31, 2012 at 19:17

I found a fix for this and I hope it works for you. I simply installed first the GCC 4.7 multilib. After doing this, it seems WINE but first with a complaint about a broken package and after clicking apply again in Synaptic, it installs.

I first installed:

gcc-4.7-multilib g++-4.7-multilib gobjc++-4.7-multilib gobjc-4.7-multilib

What I think happens is that during the installation of the multilib dev tools, it executes the correct command to configure the system to accept the i386 WINE libs that it requires. WINE is 32bit by default but I install both the 32bit and AMD64 and it seems to work great. My games play really smooth. I'm very happy with 12.10 + WINE + nVidia drivers.

Good luck!


It seems your current architecture is amd64 (dpkg --print-architecture), so you've to add i386 to the list of architectures for which packages can be installed without using --force-architecture.

So the full solution how to install wine, it would be

sudo dpkg --add-architecture i386
sudo add-apt-repository -y ppa:ubuntu-wine
sudo apt-get update
sudo apt-get install wine # or wine1.7

I faced the similar problem when installing Skype in 12.04 64bit.

I was stuck at the point where the ia32-libs was not installed and throws error message:

Cannot Install ia32-libs

Solution is to try to update all the repositories. I did it via Synaptic package manager.

Reload all the repositories and try to install wine. This may solve your problem.

It worked for me. After that there was no error in installing ia32-libs package or ia32-multarch-libs.

  • Okay. The problem is that I haven't used Wine for a couple of years, so I probably didn't try it in 12.04. I did try to install synaptic (isn't installed by default in Ubuntu anymore) and reload the repositories and search for ia32 but that didn't lead me to something that hasn't happened before. It still wants to remove a bunch of vital packages.
    – carestad
    Oct 31, 2012 at 15:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .