I installed Ubuntu 12.10 and at first when I go to check the system information I used to have (unknown) on the graphic card section, I used the synaptic manager and downloaded the fglrx, after that I restarted my laptop and now I don't have any menus, all of them are gone.

Now I am only using the keyboard shortcuts to use Ubuntu. My graphic card is AMD ATI.

What can I do to bring the menus back?

  • Is there wn ubuntu safe mode i can boot into maybe?
    – Alex
    Nov 15, 2012 at 19:07
  • I am guessing you have an AMD (ATI) graphics card? Nov 15, 2012 at 19:19
  • You can always access the terminal by pressing CTRL + ALT + F1 and do changes there.
    – mreq
    Nov 15, 2012 at 19:20
  • Please tell us what kind of video card you have, as well as the nature of the changes you made. Nov 16, 2012 at 4:00
  • Yes bruno I am, resolved now but thanks anyway
    – Alex
    Nov 16, 2012 at 15:08

8 Answers 8


Press Ctrl+shift+F1 and type this command after you logged in to the system

sudo apt-get remove fglrx-*
sudo sh /usr/share/ati/fglrx-uninstall.sh

It will remove the drivers that you have just installed, they are not compatible with the new version of the X server and will break Unity when you install them.

There is a current open bug with it on Launchpad.net, please signing and follow it for further progress. This is an ATI drivers issue:


  • After rebooting it should be back to the open source drivers and working, have a look at the bug and when its safe just install the driver again. Oct 31, 2012 at 12:44
  • I could only execute the first command. For the second one, the directory ati did not exist in my case. Thanks though.
    – myTerminal
    Apr 27, 2015 at 11:53

You can also fix it by right clicking the desktop and selecting change desktop background, then going up a level to the settings and changing the driver from the display settings back to the default one.


I successfully managed to do this this evening after having similar problems to you on the first attempt earlier in the day.

One thing I noticed after that attempt was that the kernel files in Synaptic Package Manager are very messy and reference different kernel versions. So the first thing I did was clean all that mess up.

However, you'll first need to clear up your current situation if you haven't already done so.

Open up a terminal and type:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*


Then go into Synaptic Package Manager (sudo apt-get install synaptic, if you don't already have it) and filter on "linux". Then sort alphabetically and look for the lines beginning with "linux". You'll see one file is marked for upgrade [!]. Upgrade that and reboot.

Once you're rebooted, go back into Synaptic and do the same filter again. Using a judicious install/uninstall try and make sure that all the relevant installed kernel files including "headers" type files all relate to the same kernel version. I took the latest ".18".

Once you've done that, close Synaptic and open the terminal and type the following:
sudo apt-get install linux-headers-$(uname -r)

Reboot again just for good measure and once you're back in, open up a terminal and type the following:

uname -r

You should now have the latest (.18) version of the kernel.

Open up a terminal and type:

sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases

sudo apt-get install ia32-libs lib32gcc1

This should take a fair while.
cd /usr ; sudo ln -svT lib /usr/lib64

Reboot again for good measure.

Now, go into Ubuntu software center, click Edit on the taskbar and select Software Sources. Select the middle option on the additional drivers tab and click on "apply changes".

Once that's done, reboot and then type the following into a terminal:
sudo aticonfig --initial -f

Then reboot once more.

Now all you need to do is type "amd" in dash to start Catalyst and set up the driver as you want it.

I recognise that some of the reboots may be unnecessary but this is exactly what I did and now I have a nice new Ubuntu 12.10 installation.


I had this problem too.

To revert to the open source drivers I used the method mentioned above:

You can also fix it by right clicking the desktop and selecting change desktop background, then going up a level to the settings and changing the driver from the display settings back to the default one.

That worked for me (I stumbled on how to do it - I hadn't seen this thread at the time!) but I still have the problem with the open source drivers which made me try the proprietary ones in the first place: power consumption very high/running very hot.

I achieved a partial solution using another method mentioned in this thread:

The reason is you installed the drivers with missing linux-headers-generic Install them first and then remove the drivers and re-install, reboot and all will be fine.

That allowed me to install the proprietary drivers - but with a new problem: the image breaks up, and there's a lag of several seconds, when moving/switching windows etc.

So for now I'm back to the open source drivers again.


I've just tried it with the previous linux-headers (3.5.0-17 compared with 3.5.0-18) with the same result.

So, installing the linux-headers-*-generic (that is, for example, linux-headers-3.5.0-18-generic) gets Unity to run using the proprietary drivers, but graphics performance is initially very poor.

However, I solved this by enabling "Tear Free" in Catalyst Control Center.

What I referred to above as the image breaking up, and a lag of several seconds, when for example moving a window or switching between applications, is now solved.

Hope this helps. (I have AMD HD 7670M Graphics, running on Toshiba Satellite Pro L850-13F.)


The reason is you installed the drivers with missing linux-headers-generic Install them first and then remove the drivers and re-install, reboot and all will be fine.


I had a similar problem when I tried the propriety driver on MacBookpro 8.3 Dual boot. I could login but I'd see nothing. I could right click and see a drop down menu. I could also launch the terminal (alt+ctrl+t) But I could not see any menu. I tried to revert the driver to use the open source one (as suggested by @alex in the 2nd answer by right clicking -> change desktop background -> going up to settings -> software resources -> additional driver)but it did not work; although this solution worked for me once before.

What finally worked for me (from another thread) Open virtual console : Ctrl+Alt+F1

sudo apt-get update
sudo apt-get install ubuntu-desktop
sudo dpkg-reconfigure ubuntu-desktop
sudo reboot

Then try to login, This will bring back your desktop


I had the same problem. I solved the problem as in the answer on Unable to boot ubuntu 12.10 after installing latest amd catalyst drivers The logo disapeared, but logging in on Ubuntu (standard), showed that menus where not there. But logging in as guest worked (??) I installed a temporary account, logged in once on this account. Then I logged in on my own account. Terminal session as root. I chown-ed the files of the new user as my own, and copied this files on my own files in the users directory. Logging out and in again. That worked!


You are experiencing the wrong screen resolution, that is why you are only seeing part of your desktop. To change the resolution do this.

You can use the command in your terminal xrandr -q to see what resolutions are available for your display

Xrandr is used to set the size, orientation and/or reflection of the outputs for a screen. It can also set the screen size.

To change the screen resolution to 1024 by 768 for instance, you would type: xrandr -s 1024x768

Just use that to change it to the size you want.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .