I have Windows XP installed in my VirtualBox. The integrated webcam is working fine in Ubuntu but Windows XP can't recognize it (can't find the webcam in device manager, and it doesn't ask for driver installation either). My computer is Lenovo T410 and I have installed Guest additions. What should I do now? Thank you.

UPDATE1: It works when I run virtualbox with root privileges, but this doesn't seem to be a good solution.


4 Answers 4


USB-passthrough for an USB webcam was introduced with Virtual Box 4.3.x. Make sure to install and run the latest version. To make use of USB the following procedures may still be needed:

First make sure we had set up VirtualBox, and our user permissions/groups for USB support:

Some USB devices may need an USB-Filter rule in Virtual Box to be recognized.

This is done by adding an "empty" USB filter in the USB settings of your machine:

enter image description here

This may already help recognizing your device.

If the device was still not recognized we may further specify USB properties with a right click on the "New Filer 1". This opens a settings window with some explanatory tooltips for each entry:

enter image description here

The product ID and the vendor ID needed here for your webcam will be listed on

lsusb -v

Read also the Virtual Box manual for an explanation of these settings and how to get them.

For an USB device to be recognized proberly in Virtual Box we may have to upgrade it to the PUEL Version.

Some devices may still not be reliably detected. Rarely the Virtual Machine will be unable to boot when we had defined a filter for a certain USB device. This device then should not be included in the filter rules.

  • 1
    hi, I tried to enter the vendor ID and product ID but it still can't recognize the webcam. Not sure if PUEL version means the extension pack, but if that is the case, I have installed it already. When I try to run virtualbox with root privileges, my webcam does appear in the list and it works perfectly in my Guest OS. However, I don't think running as root is a good choice, any idea how to solve this? Thank you!
    – boh
    Nov 1, 2012 at 6:40
  • yes, I am in that group but the webcam is still unlisted.
    – boh
    Nov 2, 2012 at 8:31

Its very simple.

  • First install gnome-system-tools because the old users and groups GUI is not available by default on 11.10.
        sudo apt-get install gnome-system-tools
  • After the installation finished, open user and groups from the launcher.
  • Select your username click on "Manage Groups" and select "vboxusers" and click "add".

View image

  • logout/login to be able to use USB in VirtualBox.

View image

Click Add Filter From Device and select your webcam,

  1. Add your user to the vboxusers group:

$ sudo usermod -a -G vboxusers $(whoami)

  1. Logout from your desktop and login again. If you open a terminal you can check that the group appears at the end of your group list:

$ groups jorge adm cdrom sudo dip plugdev lpadmin vboxusers

  1. Now if you go to Settings -> USB and check the Enable USB Controller option you should be able to access your device when you click on the Add icon.

If you are still unable to make it work, you may need to enable USB 2.0 support. In order to do that you will have to install the VirtualBox Extension Pack first.

  1. Make sure you download the correct file by checking first your VirtualBox version under Help -> About VirtualBox...

  2. Go to https://www.virtualbox.org/wiki/Download_Old_Builds and look for your VirtualBox version. Click on the Extension Pack -> All Platforms link to download and install the proper .vbox-extpack file.

  3. Now if you go back again to Settings -> USB you should be able to check the Enable USB 2.0 (EHCI) Controller option and then add your camera device.


in settings, have virtualbox "list all usb devices"

If you still have USB problems, you can do what i do and start Virtualbox as root.

Is it recommended? No. Does it work? Does for me.

  • Yes, it works for me but it seems risky to do so, any idea to make it work without using root?
    – boh
    Nov 1, 2012 at 6:35
  • Theres really no serious risk when running virtualbox as root. It cant make changes that would do anything of importance. Even if you did get a virus, it would be in the virtual machine, and wouldnt interact with the host.
    – TardisGuy
    Nov 2, 2012 at 7:14
  • yeah, I know but if I don't need to run it as root, I can search it using the HUD; plus it's good to learn and understand the problem right?
    – boh
    Nov 2, 2012 at 8:34
  • 2
    Never run virtualization software as root! (except sometimes for setting it up)
    – guntbert
    Aug 17, 2013 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.