Removing the package from cache, and disabling Recommended Updates in Software Sources gives me an error saying I need to install this package.

I've tried to update several times, but it keeps hanging on unpacking the ubuntu-sso-client package. Which forces me to hard-reset to unlock the package manager.

I've tried:

sudo dpkg --configure -a

No errors

sudo apt-get upgrade --fix-broken

Wants me to reinstall said package, resulting in it hanging

Removing the package:

sudo rm -f /var/cache/apt/archives/ubuntu-sso-client_1.0.8-0ubuntu1_all.deb 

Results in the same effect, it re-downloads then hangs

I can de-select Recommended Updates but I get error messages when I try to update again:

E: The package ubuntu-sso-client needs to be reinstalled, but I can't find an archive for it.

Which won't let me continue

Finally re-enabling the source, I try to remove ubuntu-sso

sudo apt-get remove ubuntu-sso-client

It removes a bunch of other packages but complains about the package:

dpkg: error processing ubuntu-sso-client (--remove): 
Package is in a very bad inconsistent state - you should 
reinstall it before attempting a removal.

Reinstalling ubuntu-sso-client hangs :(

I'm at my wits end, any ideas? I would be nice to install all the other updates but this one is preventing it.

1 Answer 1


Try dpkg --force-help. And let the Force be with you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.