2

I installed Ubuntu 12.10 on my computer (alongside Windows 7) from a live cd, but when I rebooted my computer after a successful installation, I get a grub> prompt. When I type boot in it, it prints

Error 8: Kernel must be loaded before booting

So I searched and I found Loading Ubuntu From Grub, but when I type linux /vmlinuz root=/dev/sda5 I get this message

Warning! No such command: linux

Does anybody have any idea about what I should do ?

Note that I reinstalled Ubuntu but still get the same issue, and that this is not my first time installing Ubuntu (I installed many versions a dozen times before and this is the first time I've faced this issue).

When I type : kernel /vmlinuz root=/dev/sda5 instead of : linux /vmlinuz root=/dev/sda5 I get Error 15: File not found (I also tried sda4 since find /vmlinuz is printing hd(0,4))

  • Normally I would recommend boot repair in this situation. However as the unanswered question is seven years old the OP has probably got system to boot by now. VTC as went away on its own. – WinEunuuchs2Unix Aug 12 at 12:41
0

Have you tried booting from a livecd, chrooting into your ubuntu partition(s), and manually running '# grub-mkconfig -o /boot/grub/grub.cfg'?

  • Thank you for your answer, When I do as you said, I get this error : /usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?). – Oussama Oct 30 '12 at 17:09
  • You did not chroot into your ubuntu partition correctly. First create a directory in /media (e.g # mkdir /media/ubu). Then mount your ubuntu / partition into that directory (e.g # mount /dev/sda1 /media/ubu note that this example depends on which partition is mounted as / in ubuntu). Then # chroot /media/ubu. At this point, the grub command should work. – astex Oct 30 '12 at 19:25
  • You have to find the right partition which not easy at beginner level. If you just installed it and you do not have data etc. you would need I would in your place install again. But why Ubuntu 12.04? Since the latest stable is over v19? – Alpy Mar 2 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.