I have an external NTFS hard drive. It automounts with rwx rights for the active user. I am able to create directories, update files, write to existing files, change names of files, etc.

What isn't working is creating new files. Not in newly created directories, nor anywhere else. Under Windows my drive has currently only one user (everyone) with full access.

I also tried using fstab and NTFS-3G to mount the drive with different kind of permissions, but the results are the same: I can't create new files.

Any suggestions on how to solve this?

  • Can you show full dir/file permision on the ntfs disk? – Flint Oct 30 '12 at 7:30
  • If you have an entry in fstab for this drive, you have to show us the line or have a look here at these questions 1) How to automount NTFS partitions? 2)Permanently mounting Windows' NTFS partition, fully enabled – NickTux Oct 30 '12 at 8:19
  • @Flint permissions: bert@NARCIS:/media/RONIN$ ls -al total 201 drwx------ 1 bert bert 24576 okt 30 07:50 . drwxr-xr-x 4 root root 4096 okt 30 16:44 .. drwx------ 1 bert bert 4096 okt 23 05:35 audio -rw------- 1 bert bert 92 okt 28 16:24 Autorun.inf drwx------ 1 bert bert 4096 okt 29 21:40 Documents at NikTh I'm currently using fuseblk (beceause it worked before) I tried 1) and 2) but with the same results: I can modify existing files, but not create new ones – Bert Oct 30 '12 at 15:46

Sorry if I wasn't clear v2r

There is another box to tick if you click advanced but that is if you have more than 1 NTFS partition but if you only have 1 NTFS partition it should be ticked as default but look anyway just to make sure otherwise there are only 2 boxes to tick.

1 box is called "Enable write support for external devices" and the other box is called "Enable write support for internal devices" so depending if your NTFS drive is internal or external tick the relevant box.

Sorry I can't give you screenshots not enough rep points yet but I'll replace the url typed at the bottom with a screenshot as soon as I have enough points it will have an example of NTFS Configuration Tool or type NTFS Configuration Tool in Google image search.

enter image description here

Edit: This method worked for me.

Open up Ubuntu Software Centre and type NTFS and install NTFS Configuration Tool (it should be the first one in the list of results). Once installed run NTFS Configuration Tool and tick both boxes and now you should have full access to to your drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.