I have this entry in .xsession-errors log

"Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned

error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares.         
Error No such file or directory
Please ask your system administrator to enable user sharing.

This is in relation to my applets having to be reloaded after every boot. Just wondering how I would enable user sharing, and how it affects my applets ??


Actually, you have to install samba if you want to not see the error. But the use of Samba is for file or printer sharing with other unix or window systems. So you can ignore the error or just install samba.

  • 3
    This fixes the error for me – Peter Jenkins Jan 23 '13 at 13:04
  • @Mika, Samba is for file sharing as well. – ivant Jun 24 '15 at 6:44

I don't think this effects your applets at all, that's probably a different bug. You could just make the directory with sudo:

sudo mkdir -p /var/lib/samba/usershares

But I don't really know what it will do.


I sort this problem creating a group call admin:

sudo groupadd admin

Check that the admin group is part of the sudoers:

sudo cat /etc/sudoers

Now you add your user to the admin group :

sudo usermod -aG admin username

you can check if your user is part of the group :

sudo cat /etc/group | grep '^admin'

this worked for me

  • 1
    Can you explain why this fixes the problem? It seems a bit strange to give yourself extra permissions to work round a nautilus bug. – Peter Jenkins Jan 23 '13 at 13:03
  • this worked for me – rubixibuc May 10 '14 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.