Today I installed:

  1. Ubuntu 12.04
  2. Oracle JDK 7 and 8
  3. IntelliJ 11.1.4

I setup my JAVA_HOME path to point to JDK 7.

When I run IntelliJ I get this message:

Gtk-Message: Failed to load module "canberra-gtk-module"

Is this a problem or can I over look this?

  • This is a fairly generic message. And a lot has changed since this question was posted. No more 32-bit versions are considered modern, for one. I posted the simple answer below that works in July 2017. Simply install that module. That's it. – SDsolar Jul 31 '17 at 8:51
up vote 60 down vote accepted

I fixed this by installing the module:

sudo apt-get install libcanberra-gtk-module

Or if it's already installed and you still get the error:

sudo apt-get install libcanberra-gtk-module:i386
  • 2
    I have libcanberra-gtk-module already installed and it is still showing the error. any ideas? – Jim Ford Jun 4 '14 at 15:44
  • 1
    @JimFord See askubuntu.com/questions/342202/… – belacqua Jul 8 '14 at 15:48
  • 1
    I know this answer was written 4 years and 9 months ago, but here in July 2017 there are no more modern i386 versions being offered. They have become specialty items, mostly for maintenance purposes. So I posted a similar answer below, omitting the confusion about which command will work for you. – SDsolar Jul 31 '17 at 8:48
  • Used for LibreOffice in a docker container – MrMesees Aug 31 '17 at 21:14

This question is 4 years and 8 months old. It is now July 2017.

On a Raspberry Pi 3B running Raspbian Jessie and Ubuntu 16.04 LTS I was getting this error.

Failed to load module “canberra-gtk-module”

It is fairly generic.

The good news is that the fix is easy. Simply enter:

sudo apt-get install libcanberra-gtk-module

installed some stuff...

Then it never showed up again.

happened with a qt5 application using gtk theme on Ubuntu MATE

$ ./my-application
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "topmenu-gtk-module"

let's locate the libs

$ locate libcanberra-gtk-module.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libcanberra-gtk-module.so
/usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libcanberra-gtk-module.so

setting the LD_LIBRARY_PATH solves the issue

$ LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/gtk-3.0/modules:$LD_LIBRARY_PATH ./my-application

or unset the GTK_MODULES environment variable

$ unset GTK_MODULES; ./my-application

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.