On trying to install Ubuntu 12.10 Desktop amd64 to a desktop pc using a ga a75 ud4h motherboard (which is using an AMD 3870k APU with a new 1TB HDD) following the advice in the motherboard manual and https://help.ubuntu.com/community/UEFI have now got to grub option screen for EFI install.

Booting live dvd in EFI mode gives "Secure Boot is not enabled" just before grub kernel option list shows. EFI install

If the option to "Install Ubuntu" or "Try Ubuntu without installing" is selected gives "can not read cd/0" and "the kernel must be loaded first" errors.

Using DVD or USB installation media gives same results and there has never been at any point an UEFI entry in bios/firmware settings or boot device list/s.

It might be helpful to say that have had an alternative non-linux OS installing EFI mode on this hardware giving a GPT installation automagically using USB installation media when the hdd space was completely unallocated space. The USB device was listed under hard drives in bios/firmware one time boot list and did not have an UEFI entry. i.e. it installed EFI although no EFI or UEFI entry was assigned to the device like what is shown in many tutorials regarding UEFI installs.

The only constructive information regarding this question is found at wiki.ubuntu.com/EFIBootLoaders and rodsbooks.com/gb-hybrid-efi but can not work out the answer.

Checking md5sum and sha256 checksums on downloaded .iso and used "Check disk for defects" to check burned .iso when booting DVD in BIOS mode. No errors found. "Check disk for defects" will not run (or any other options) when DVD booted in EFI mode.

Due to trying different distributions as well as older and newer flavours of Ubuntu all giving similar results in that no options from grub option screen in EFI mode are bootable (if getting that far) as well as spending time searching Ubuntu Forums have come to conclusion the firmware on this system is hardcoded to handle Microsoft EFI files only.

After installing Windows EFI mode here is a boot info script and here is a link to a thread i started at Ubuntu forums which may be helpful to others building a dual boot system.

Installing BIOS mode and using Boot-Repair to install grub-efi is not a complete solution due to the inability of using installation media EFI mode for recovery and maintenance due to the "you need to load kernel first" and "can not read cd/files" errors as described when trying to boot installation media using EFI.

Secure Boot is not an issue. Using msinfo32 from windows confirms Secure Boot is not supported on this hardware.

How to edit kernel or load kernel for EFI install? = How to EFI install Ubuntu?

PLEASE CONSIDER: This is not a dupe! The linked question that is indicated to having a working answer does not have a working answer to "###How to edit kernel or load kernel for EFI install? = How to EFI install Ubuntu?" therefor the workaround of installing using BIOS then manually install grub-efi without renaming bootloaders which works to get Ubuntu booting using EFI or using boot-repair to do this (and many unnecessary "fixes" if recommended repair is not changed in advanced settings) also works. This goes some way to confirming hardcoding of firmware is not stopping grub the boot manager seeing the vmlinuz.efi files in /casper on DVD. I would like an answer to this so would like this question to be reopened.


3 Answers 3


It is possible that some BIOS's option is disabling the EFI correct behavior. Have you tried to enable the EFI options in the BIOS before booting the dvd? Also, it is possible that the signed lock is causing problems during the boot. Check these things and good luck!

  • 1
    :) Try 12.10, I am really satisfied with it. Nov 2, 2012 at 10:20
  • 1
    I installed it with uefi Nov 4, 2012 at 18:33
  • 1
    I installed the Gnome Remix flavour. First, I configured my Bios to boot in UEFI mode. In second place, I booted from the usb in UEFI mode, and, while the disk image has an error (the live loader points to a non-existing vmlinuz.signed file) I edited the grub commandline to point to the correct one. Next, i formatted my Hdd to a GPT system and installed ubuntu gnome. Nov 4, 2012 at 20:43
  • 2
    Reading the question now shows all the information that is suggested by fernando garcia has been considered and worked through. Reading motherboard manual confirms no bios settings to change due to very rudimentary EFI implementation. Selecting DVD EFI on and setting SATA to AHCI is enough to boot hard drive and DVD EFI mode. Using msinfo32 from windows confirms Secure Boot is not supported. Have tried to remove upvote but is locked until this answer has been deleted by fernando garcia.
    – geezanansa
    Aug 15, 2013 at 21:39
  • 2
    Had flagged this answer as not an answer but others do not see my efforts to update nor have read the question and its links. ##THIS IS NOT AN ANSWER.## Unfortunately fernando garcia has not updated answer according to updates to question or reacted to my comments. Which were removed after updating question. Although he does indicate it is possible to edit kernel options in order to boot kernel using EFI mode.
    – geezanansa
    Aug 15, 2013 at 21:40

This is by no means a fully working answer but will be updated as and when I can-that is if and when necessary.

Have a Hybrid EFI system here which means selecting dvd EFI mode and ensuring SATA set to AHCI in BIOS settings will force BIOS to boot hdd in EFI/GPT mode and allow any installer with a suitable EFI boot image to run in EFI mode when booted from DVD device. If there is no valid EFI boot image to load then the BIOS installer will run which would give a MBR partition table installation = legacy.

Have managed to get an EFI windows install but not worked out Linux yet. Am sure the answer is here and referring to this confirms there is no EFI shell or GUI for EFI available because of Hybrid EFI system; which may help explain the "automagical" install of Windows.
Trying to install Ubuntu alongside Windows has not been possible as Ubuntu installer does not even see/detect Windows install - that is when letting run in Legacy mode.

The UEFI specification required for Secure Boot is => UEFI 2.2 and Windows 8 pre-installed machines will use UEFI 2.3.1.
As EFI is predecessor this hardware is not Secure Boot capable. Using a signed key installation media is not going to be much use for implementing the EFI features that this hardware does possess allthough it should not make any difference that is when considering the fact that all U/EFI specification should be or are actually backward compatible. Simply means no secure boot.

Updates will follow. (or alternatively other answers!)


Use the USB installer -> Make a USB disk

you can use a flash reader (Smart phone)
Usb drive
Harddrive on a USB port. (tho youd have to reformat it)

Once you got your USB stick with UBUNTU live on it -> boot up with the (Boot Selection) Key -> ((might be f8, or f2, or esc))

Find your stick, should say "UEFI usb stick kingston" or whatever brand.


When installing you will need to make a seperate partition BUT if you do the auto "erase whole disk" thats not a problem. It will do it auto.

PENDING you cant erase the whole disk, You need to make a partition about... its either 1 or 100 MB, partition type "grub boot" at start, EXTx second partition, and swap.


  • Strange... Well I couldnt tell you any more without... Hey is there an option in your bios, should say "option rom" Change it to "Keep current"
    – TardisGuy
    Nov 4, 2012 at 22:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .