I am trying to set up a multi-boot USB stick including both standard desktop and alternate ISOs. I have both kinds of ISOs booting, using examples from a variety of places including https://help.ubuntu.com/community/Grub2/ISOBoot, and the standard install is working fine. The alternate install is not, however.

It boots, runs through the language and keyboard configuration questions, pops up a brief "Detecting hardware" dialog, and then reports:

Detect and mount CD-ROM

Your installation CD-ROM couldn't be mounted. This probably means
that the CD-ROM was not in the drive. If so you can insert it and try again.

Retry mounting the CD-ROM?

Where can I go from here?

My grub2 menu entry reads:

menuentry "Ubuntu 12.04.1 Alternate i386" {
  loopback loop $iso
  linux (loop)/install/vmlinuz boot=casper persistent iso-scan/filename=$iso noeject noprompt --
  initrd (loop)/install/initrd.gz

Burce! I haven't tried this option of grub2 recently enough,so perhaps things have changed now that I have grub2-2.0-0.39 (I run Fedora, but don't mind that)...

However, I gave it a try and (avoiding now numerous interesting issues encountered) must report, that although you will succeed in booting the kernel and initrd from your ISO, there may be no way provided in that initrd&kernel to be aware of being booted from a loopback device. Nor may it be possible to pass on to that kernel a loopback root device as an argument. Actually, I have no idea what happens to that device once kernel + initrd are loaded and booted -- that would be VERY interesting to know.

I remember having succeeded, though, in booting a kfreebsd install DVD using that feature. But at some point it hanged because of not being able to "find the installation media". So I had to go to the console, manually use losetup to loopback-mount the ISO and link it to /dev/dvd or something, for the install scripts to notice it, then go back to the installation "wizard" and tell him where the media was... And even this completely manual boot from the ISO was not always possible for the reasons mentioned above.

This is my view on the problem, but it may be incomplete and grub2 itself may have evolved. So would be interesting to hear more comments on this. Or perhaps, give it a try again when I have time for't.

Kostya Berger

  • Indeed, the kernel doesn't know that it's been booted from a loopback image, but the standard Ubuntu image includes an initrd that recognizes the iso-scan/filename parameter. If it's present, it scans partitions for the given filename, and then mounts it loopback as the root filesystem. – Bruce G Nov 29 '12 at 22:43
  • As indicated above, this is working fine for the standard Ubuntu ISO images, but not for the "alternate" ISOs. A similar process works for Fedora, see here for one discussion. – Bruce G Nov 29 '12 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.