I have 'upgraded' to Ubuntu 12.10 from a previous nice version that always worked. I have installed from a CD downloaded from this site. I start the PC (HP Pavillion zv5200) and arrive at a signon screen which has my username and "Guest". This screen shows the menu at the top with power, time, calendar, etc. So I enter my password and I am taken to a screen which only shows a wallpaper, nothing else. If I move the mouse and 'push' against the left limit I do not get a launcher app. Nothing. The only thing that works is opening a terminal (ctrl+alt+F1). I have tried several of the hot-key combinations I've read about on the site but none do anything, nothing happens. Can anyone help? Thanks very much!


I had the same problem but none of the above worked for me. Uninstalling compizconfig-settings-manager also didn't work.

In the end I found the answer here, as I was seeing the same 'Fatal: glXQueryExtensionsString is NULL for screen 0' errors in a terminal when trying to start unity. I realised I was using a proprietary ATI display driver before I upgraded from 12.04 to 12.10. I issued the commands below in a terminal:

sudo add-apt-repository ppa:makson96/fglrx 
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

and then rebooted my PC. Unity then reappeared when I logged in.

There's an explanation here of why the upgrade fails in the first place. I was using an AMD Mobility Radeon HD 3650 graphics card (ATI RV635). Use:

lspci | grep VGA

to find out what graphics card you are using.


There are know issues with restricted video drivers, compiz, and/or unity 3D (one or all or maybe something else too). If the other answers that suggest reseting compiz and unity don't work, try running unity 2D. At the login screen, right click the Ubuntu circle thing to the right of your name, click Ubuntu 2D, and login as normal.


Usually, some settings brought over from the previous version are incompatible with the current way of doing things. As of 12.10 you can no longer use 'unity --reset' to fix this, but there is a work-around.

Have a look here : How do I reset my Unity configuration?

Make sure you are following instructions for ubuntu 12.10, not the older instructions.

  • Thanks for your answer. I tried several of the proposed solutions and none worked, one required a reinstall, the two involving download resulted in 'package not found'. – Guy Wms Oct 29 '12 at 20:52

The "unity --reset" may not be working on Ubuntu 12.10 but you could try the following:


If that does not solve your problem you could try the following to reset your Unity:

sudo add-apt-repository ppa:amith/ubuntutools
sudo apt-get update
sudo apt-get install unity-reset

Then you can use the unity-reset and everything should be restored.

If that doesn't work check this site for more information:



I would like to report my trajectory and dealing with No Launcher.

  1. It started with X-server problems in 12.04. because I couldn't log in with both lightdm or gdm. I only could log in by terminal.
  2. I decided to execute do-release-upgrade to upgrade to 12.10.
  3. With the new release I found that I could only log in with gdm, but the Desktop appeared without launcher or top bar.
  4. In this forum I discovered that the Launcher problem was related with some AMD drivers.
  5. To find out what is my graphic card, I did :

    lspci | grep -i vga 02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series]

  6. I also discovered that in a terminal, I can execute the command: unity and recover my launcher. In the same terminal I had the following error:

    Compiz: Unity is not supported by your hardware. Enabling software rendering instead (slow)

  7. I installed Catalyst 12.6 Legacy driver, Now I have a permanent square in the right bottom corner, displaying: AMD Unsupported hardware.

  8. From a terminal I execute again the command: unity and recover my launcher. I feel that with this driver the laptop is not slow and is working almost normal. I am surviving like this!

My launcher started becoming hard to reveal, then was only enabled by the Super key, then after a restart was replaced with a black bar slightly to the right of where the launcher should be. I tried all the above methods to no avail.

On a hunch I created a new user and the launcher is working as it should be, but only in that user. I don't have a solution, but am guessing some evil file or device is the culprit.

Not the answer you're looking for? Browse other questions tagged or ask your own question.