3

I cannot copy films from NTFS partition on my computer (with Ubuntu) to ext2 hard drive installed in player "Dune". Please help.

11

I suspect your NTFS partition gets automatically mounted at boot. If we were speaking about i.e. a USB disk you attach to your computer, the permissions would be set correctly when you click on the volume in your file manager.

So there is probably an entry in your /etc/fstab file which looks like this:

...
someWeirdId  /media/name  ntfs  auto,stuff,stuff,stuff  0  0

change this to:

...
someWeirdId  /media/name  ntfs  auto,stuff,stuff,stuff,uid=1000,gid=1000,umask=0000  0  0

This gives ownership of the mounted volume to the user with uid 1000, which would be the first user in your system. Enter id on a terminal to see what uid and gid you have.

Setting umask to 0000 should grant all permissions to every user anyway.


NTFS and FAT cannot store posix permissions, like they are used by Linux (actually i'am not sure about NTFS, but I wouldn't know how).

However you can use the program fuse-posixovl to mount a directory (!) on any partition (regardless if posix permissions are suipported or not) to another directory (or the same directory if you feel like it). posixovl will create a file on the real filesystem storing the posix permissions you set in the other mountpoint. This way you get full posix functionality on any non-posix file system.

To be able to change file ownership, etc. you should run posixovl as root (via sudo).

sudo mount.posixovl /directory/on/ntfs/partition /directory/where/i/use/chown

As I said source and target directories can theoretically be the same, but try it with different directorys first, just to be sure.

The permissions will not be effective unless posixovl is used. So you can't protect your data when you attach the disk to friends computer or something. The files will be accessible anyway.

1

I came across this Q/As while looking for: How to change permissions in an NTFS partition?

And while the Original Question title explain correctly and concisely my issue, it seems that it's body doesn't correspond to the the title, and it's a different (but maybe related issue), So, first, I'll answer the title question, then comment on the OQ body


short answer

you need to mount the NTFS partition, with the appropriate mount options (users,permissions)

detailed answer

You can change the permissions and ownership of files and folders stored in an NTFS partition, (but not in a FAT one). Because, as it's nicely explained in this answer NTFS is a POSIX-compatible filesystem.

Although, it is usually unneeded¹ for copying/editing files in an NTFS partition from a linux one (in case of dual-boot)


  1. NTFS partition on read only? enable write/read

    By default Windows system on laptops doesn't perform a full shutdown, when you shutdown the system. Which makes the partition accessible on read only mode.

Perform a Full Shutdown of windows, by either:

  • holding down the SHIFT key on your keyboard and then click the “Shut down” option in the Start Menu.

  • or, type the following, in Windows Command Line (cf. Shutdown | Microsft doc)

shutdown /s /f /t 0

Or just disable Hibernate / Fast startup windows' "features" permanently, to make all eventual shutdown == full shutdown(cf this question for more info)

This, in most cases, is enough to make you able to access and edit all files in a windows partition.

But if you still need to "chown the NTFS partition" then


  1. change NTFS partitions mount option, either by :
  • editing /etc/fstab using:
sudo -e /etc/fstab

Either way, the options that you most have are: users,permissions, and you don't need to have nosuid option, since it's implied by users (cf. Bovine comment)

so, the /etc/fstab entry for the NTFS partition should looks like:

# <file system> <mount point>   <type>      <options>                           <dump>  <pass>

FILE_SYS_UUID   /mnt/Win_D      ntfs-3g     users,permissions,x-gvfs-show,...   0       0

Note: if you are using a very old Ubuntu, or a distro that doesn't use ntfs-3g for NTFS file by default, make sure to change file system type to ntfs-3g instead of ntfs or auto, otherwise they're the same (cf. this answer)


  1. chown/chmod it as you like

About the Original Question

Copying files from a directory D_src to a D_dest requires read right only on D_src, and read/write rights on D_dest

So, in case you want just to copy some files from an NTFS D_src partition, that you are able to access on read only mode, to an ext partition D_dest. you don't need to change the former permissions. but looks into the latter

Some additional info & a warning

In addition to the default windows setting on laptops, that make NTFS partitions read only, you may get a similar behavior in the case of hanging updates. so make sure you don't have one.

It goes without saying, but I'll say it nevertheless:

The process described above will give you the power to edit the file system of a Windows or NTFS partition the same way as a linux one, which may be dangerous if you don't know what you're doing. So make a backup maybe, and get a Boot-Repair just in case


3
  • 1
    Doesn't the users option imply nosuid by default? Or has that been deprecated? I would think you'd need to specify users,suid if you wanted both. Overall, nice answer!
    – Bovine
    Dec 14 '21 at 15:38
  • Yes, you're right; I guess I need to edit "should not have" to "don't need to have"
    – 4015.alt
    Dec 14 '21 at 16:26
  • for ref; nosuid Block the operation of suid, and sgid bits. While users Allow every user to mount and unmount the filesystem. and it implies the options noexec, nosuid,
    – 4015.alt
    Dec 14 '21 at 16:27
0

You can chown your NTFS partion:

sudo chown -R username:username /dev/sdbx where you would want to replace sdbx with the correct sdb.

run sudo fdisk -l to figure out your sdb

3
  • 3
    no! this will not affect the mounted file system, it's useless for the problem case. (although technically, yes, you would chown the partition) Oct 29 '12 at 18:59
  • @PaulHänsch I don't quite get it. Ubuntu is probably installed on the ext partition while the NTFS partition just has stuff right?
    – dearN
    Oct 29 '12 at 19:00
  • 4
    when you mount a filesystem, the permissions of the files on this filesystem have no relationship to the permissions of the block device from which the filesystem was mounted. Set permissions for a block device only to grant raw device access to a user, i.e. creating a file system (aka. formating the device) or partitioning a hard disk. Oct 29 '12 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.