The combination for select all (Ctrl+A) doesn't work in a browser (either if we speak about firefox or chromium). It doesn't work if I try to clik in to the adress bar nor if I try to use it to select what I've written in google search bar at google.com. When I press Ctrl+A it simply takes the cursor before the first letter. This doesn't happen when I use a text editor software like Libre Office. There the shortcut does what's supposed to do, selecting all the text.

What could be the problem?

  • File it as a bug report, it works on my 12.04 system.
    – January
    Commented Oct 29, 2012 at 17:59
  • 2
    Did you enable Emacs style keybindings? kb.mozillazine.org/Emacs_Keybindings_%28Firefox%29
    – ijk
    Commented Oct 29, 2012 at 18:03
  • 1
    Also do you get the same problem from a freshly created user account?
    – ijk
    Commented Oct 29, 2012 at 18:04

8 Answers 8


Had the same problem in 12.10 and it was driving me mad. The problem seemed to be caused by using the Emacs key binding theme as described in the links given by others, except that according to GConf I was still using the default.

I realized that this is now set in dconf Editor irrespective of the settings in GConf.

To change this open dconf Editor and navigate to:
org > gnome > desktop > interface >gtk-key-theme.
If the setting there is Emacs change it to Default.

Or on a terminal:

gsettings reset org.gnome.desktop.interface gtk-key-theme

Problem solved. For me at least.


I had this same issue happen in both Ubuntu 12.10 and Mint 13. The way I fixed it was by going in through ccsm and changing my themes back to defaults.

The Gtk+keybinding theme EMACs was the issue, when I returned it to default it fixed the issue and all other themes were working fine.

  • This can be done in later versions of Ubuntu with gsettings set org.gnome.desktop.interface gtk-key-theme "Default"
    – apg
    Commented Nov 21, 2019 at 14:53

Not sure what's wrong with your keyboard shortcuts, but this might help for Firefox; enter about:config in the address bar and then 'select' && the two options that can be useful are:



(Just set them to the opposite of default :))


Ubuntu Tweak fixed this problem for me.
This is the updateed tweak tools as of Jan 2015 :

Tweak Tools -> Keyboard and Mouse -> Key theme set to : default

  • in many versions of tweektools your answer works for me, thx ! Commented Oct 3, 2016 at 3:18

Use gnome-tweak-tool:

Set Theme > Gtk + Keybinding Theme to: Default



gsettings set org.gnome.desktop.interface gtk-key-theme "Default"

as this resets the option without having to go through the tweak tool, which doesn't have the right option available in Themes in 18.04.


Had the same issue on Ubuntu 20.04 and has been bothering me for some time now, turns out I had option Emacs Input enabled in Gnome Tweak Tool.

Turning it off solves the issue.

Open Gnome Tweak Tool, under Keyboard & Mouse section, turn off option Emacs Input

Gnome Tweak Tool


Though this thread is quite old, it helped me find the solution of my problem.

I am running Debian 12 / wayland and the CTRL-A key did not work no more, either ti select all text in a text area or to go to the beginning of line in shell or in emacs.

By de-activating the emacs flavor in gnome tweak tool (or using

gsettings set org.gnome.desktop.interface gtk-key-theme "Default" 

as suggested), the CTRL-A key is operating correctly everywhere.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .