6

The combination for select all (Ctrl+A) doesn't work in a browser (either if we speak about firefox or chromium). It doesn't work if I try to clik in to the adress bar nor if I try to use it to select what I've written in google search bar at google.com. When I press Ctrl+A it simply takes the cursor before the first letter. This doesn't happen when I use a text editor software like Libre Office. There the shortcut does what's supposed to do, selecting all the text.

What could be the problem?

6

Had the same problem in 12.10 and it was driving me mad. The problem seemed to be caused by using the Emacs key binding theme as described in the links given by others, except that according to GConf I was still using the default.

I realised that this is now set in DConf irrespective of the settings in GConf.

To change this open DConf and navigate to:

org > gnome > desktop > interface >gtk-key-theme

If the setting there is Emacs change it to Default.

Problem solved. For me at least.

| improve this answer | |
4

I had this same issue happen in both Ubuntu 12.10 and Mint 13. The way I fixed it was by going in through ccsm and changing my themes back to defaults.

The Gtk+keybinding theme EMACs was the issue, when I returned it to default it fixed the issue and all other themes were working fine.

| improve this answer | |
  • This can be done in later versions of Ubuntu with gsettings set org.gnome.desktop.interface gtk-key-theme "Default" – apkg Nov 21 '19 at 14:53
4

Not sure what's wrong with your keyboard shortcuts, but this might help for Firefox; enter about:config in the address bar and then 'select' && the two options that can be useful are:

browser.urlbar.clickSelectsAll

browser.urlbar.doubleClickSelectsAll

(Just set them to the opposite of default :))

| improve this answer | |
2

Ubuntu Tweak fixed this problem for me.
This is the updateed tweak tools as of Jan 2015 :

Tweak Tools -> Keyboard and Mouse -> Key theme set to : default

| improve this answer | |
  • in many versions of tweektools your answer works for me, thx ! – Vladimir Ch Oct 3 '16 at 3:18
2

Use gnome-tweak-tool:

Set Theme > Gtk + Keybinding Theme to: Default

| improve this answer | |
2

Try

gsettings set org.gnome.desktop.interface gtk-key-theme "Default"

as this resets the option without having to go through the tweak tool, which doesn't have the right option available in Themes in 18.04.

| improve this answer | |
0

Had the same issue on Ubuntu 20.04 and has been bothering me for some time now, turns out I had option Emacs Input enabled in Gnome Tweak Tool.

Turning it off solves the issue.

Open Gnome Tweak Tool, under Keyboard & Mouse section, turn off option Emacs Input

Gnome Tweak Tool

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.