Possible Duplicate:
Cannot make NVIDIA driver work with Ubuntu 12.10

I decided to upgrade both my computers from Precise to Quantal. What a mistake that was.

My laptop has a nVidia GT 330M card, while the desktop has an nVidia 9600 GT. In both cases everything goes great as long as I use the Nouveau driver (ugh!). Can't really play games (Amnesia... and hoping for Steam Beta participation...), even though it's OK for work.

Now, ever since 9.04 or so, I just installed nvidia-current and all just worked. Since 12.10, after installing nVidia drivers, Unity won't start at all (hangs with only the wallpaper displayed, no cursor or widgets), Gnome Shell is permanently in fallback mode.

Now, I have tried on both computers, with multiple clean installs on Ubuntu (two separate downloads, just in case), one from Ubuntu Gnome Remix. And additionally, Fedora 17, which seems to suffer from the same issue. Tried all nVidia driver suggestions available in Software Sources, and even compiled the drivers myself. I tried several versions of the driver to exclude an issue with the newest one.

In my frustration, I have switched to Windows (which, ironically, "just works" with my hardware), but still hold a twin OS configuration on the desktop and would like to use Ubuntu again. So, can anyone point me to where the issue might lie?

marked as duplicate by belacqua, user76204, Tom Brossman, hexafraction, Ringtail Oct 30 '12 at 3:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This worked for me [cannot-make-nvidia-driver-work-with-ubuntu-12-10][1] [1]: askubuntu.com/questions/207368/… – William Bell Oct 29 '12 at 18:51
  • Regrettably, that post does not solve anything for me - rebooting was the very first thing I did after installing the drivers. – mingos Oct 29 '12 at 18:58

I was having the same problem, then I found a post which addressed this issue and a link to this website. http://bumblebee-project.org/install.html#Ubuntu The problem you are encountering is most likely related to optimus, which does not have official support for Linux. Bumblebee aims to fix that.

  • My desktop computer does not rely on Optimus, so, uh... no :) – mingos Oct 29 '12 at 19:02
  • You never specified which computer had the problem, so I assumed both and thought this would help the the laptop at least. – Mysteriousness Oct 29 '12 at 19:11
  • Both have this problem, this is correct. However, I only have Ubuntu installed on my desktop right now, as I needed a working OS on the laptop immediately and installed Windows on it. However, I believe the Toshiba A500-1EE model actually does support Optimus and had I not switched to Windows there, I'd definitely try bumblebee :). – mingos Oct 29 '12 at 19:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.