1

Problem

I have a Dell mini 9, and the wireless has worked without trouble in Ubuntu and Xubuntu versions 8.04 and 10.04.

However, after installing lxde, the wireless doesnt connect. Network manager recognizes the local networks, and will say that it is connected, but ifconfig does not confirm the connection or the existance of a wlan0.

I have another Ubuntu 10.04 notebook that works fine.

My wireless device is Broadcom BCM4312 802.11b/g

What I have tried

I have tried to remove and install network-mananager and inxi but neither work, and

sudo modprobe wl returns

WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.

1

This is a weird issue, it sounds like network manager is broken or the configuration is broken. Although I can't see how lxde could have caused that issue.

Can you boot up using a LiveUSB and see if your broadcom wireless works? Make sure to add in the binary blob using jocky from System > Administration > Hardware Drives. Once you've confirmed the hardware is fine, you have three options:

  • Reinstall Ubuntu
  • Attempt to investigate the issue (you really need direct access to the machine to do this right)
  • Attempt to find an expert to look at it.

Sorry that I can't find an easy solution for you.

  • I have confirmed that the hardware is fine, and I have also tried this on both the standard and Mint versions of Lubuntu. I have direct access to the machine, so that is okay. Where can I find an expert if not here? – David LeBauer Jan 10 '11 at 2:55
  • @David, the expert would need direct access to your machine. Since the problem is with your install and we have no idea what could be wrong with it. – Martin Owens -doctormo- Jan 10 '11 at 4:29
  • if the problem is with the install, it seems that the problem would have occurred with either the Lubuntu or Mint versions of Lxde, but not both. – David LeBauer Jan 10 '11 at 5:37
  • You didn't say that it failed to work in those other two, I read what you said as saying that it worked in those other two. Do you have the boradcom firmware installed? – Martin Owens -doctormo- Jan 10 '11 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.