I am running 12.04 LTS completely update.

When logging in on the command line, I see this message

*** /dev/sda1 will be checked for errors at next reboot ***

I've rebooted once and got the message upon logging in on the command line; then used the sudo touch /forcefsdk command and rebooted; and I still get this message.

How can I clear the message, and does it really make a difference?

If it helps this system shutdown uncleanly due to a power failure, but has rebooted and acted fine since.

cat /etc/fstab

 ics@steamboy:~$ cat /etc/fstab
    # /etc/fstab: static file system information.
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sda1 during installation
    UUID=a15471c6-56f1-419f-89fa-73a5f3c7253e /    ext4    errors=remount-ro 0       1
    /dev/sdb1 /media/xtra    ext3 errors=remount-ro 0 1

    # swap was on /dev/sda5 during installation
    UUID=a544f2c5-6e09-44ec-8130-a524a12a99c0 none        swap    sw              0       0
    /dev/sdc0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

cat .bashrc

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything [ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace HISTCONTROL=ignoredups:ignorespace

# append to the history file, don't overwrite it shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1) HISTSIZE=1000 HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS. shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1) [ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below) if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
     debian_chroot=$(cat /etc/debian_chroot) fi

# set a fancy prompt (non-color, unless we know we "want" color) case "$TERM" in
     xterm-color) color_prompt=yes;; esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt

 if [ -n "$force_color_prompt" ]; then
     if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then  # We have color support; assume it's compliant with Ecma-48     #
 (ISO/IEC-6429). (Lack of such support is extremely rare, and such  # a
 case would tend to support setf rather than setaf.)    color_prompt=yes
     else   color_prompt=
     fi fi

 if [ "$color_prompt" = yes ]; then
 ' else
     PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ ' fi unset color_prompt force_color_prompt

 # If this is an xterm set the title to user@host:dir case "$TERM" in xterm*|rxvt*)
     PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
     ;; esac

 # enable color support of ls and also add handy aliases if [ -x /usr/bin/dircolors ]; then
     test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
     alias ls='ls --color=auto'
     #alias dir='dir --color=auto'
     #alias vdir='vdir --color=auto'

     alias grep='grep --color=auto'
     alias fgrep='fgrep --color=auto'
     alias egrep='egrep --color=auto' fi

 # some more ls aliases alias ll='ls -alF' alias la='ls -A' alias l='ls -CF'

 # Alias definitions.
 # You may want to put all your additions into a separate file like
 # ~/.bash_aliases, instead of adding them here directly.
 # See /usr/share/doc/bash-doc/examples in the bash-doc package.

 if [ -f ~/.bash_aliases ]; then
     . ~/.bash_aliases fi

 # enable programmable completion features (you don't need to enable
 # this, if it's already enabled in /etc/bash.bashrc and /etc/profile
 # sources /etc/bash.bashrc). if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
     . /etc/bash_completion fi


 export CVSROOT=:ext:cvsuser@revision_control:/home/cvsuser/SRC_TREE
 export CVS_RSH=ssh

 export TERM=vt100

 if [ "`tty`" != "not a tty" ]; then    stty clocal     stty erase      stty
 echoe fi

 export TERMCAP=/etc/termcap.RHEL3 export EDITOR=vim

 export PYTHONPATH=/home/cnorton/bin:/home/amr/bin:$PYTHONPATH

 export PYTHON_EGG_CACHE=/tmp/cnorton/.python-eggs export

  • Edit your question and add the results of cat /etc/fstab & cat .bashrc – NickTux Oct 29 '12 at 13:21
  • Could not get .bashrc to format correctly. Sorry. – octopusgrabbus Oct 29 '12 at 13:41
  • 1
    I just rebooted again; could not get a boot menu by pressing either SHIFT or ESC, but the message is now gone. – octopusgrabbus Oct 29 '12 at 13:47
  • You have to hold the SHIFT down. Not just pressing (one or two times). – NickTux Oct 29 '12 at 15:01

I don't know if your .bashrc file creates this problem , as is not the Official.

The standard .bashrc file ends here

. /etc/bash_completion fi

All bellow are either your additions of some program's additions.

As for the fstab , seems good. The only "mistake" I can see is the fsck.order in /dev/sdb1

Fsck order has to be 1 only for root partition. Any other partitions should have 2 .

So the correct line for /dev/sdb1 is

/dev/sdb1 /media/xtra    ext3 errors=remount-ro 0 2

Correct this and see if your problem solved.

Also read here a good tutorial on How-to Fstab

Linked Q&A:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.