When running sudo apt-get update I get these following errors:

Err archive.ubuntu.com quantal InRelease
Err archive.ubuntu.com quantal-updates InRelease
Err archive.ubuntu.com quantal-backports InRelease
Err archive.ubuntu.com quantal-security InRelease
Err archive.ubuntu.com quantal Release.gpg
  Unable to connect to archive.ubuntu.com:http: [IP: 80]
Err archive.ubuntu.com quantal-updates Release.gpg
  Unable to connect to archive.ubuntu.com:http: [IP: 80]
Err archive.ubuntu.com quantal-backports Release.gpg
  Unable to connect to archive.ubuntu.com:http: [IP: 80]
Err archive.ubuntu.com quantal-security Release.gpg
  Unable to connect to archive.ubuntu.com:http: [IP: 80]
Reading package lists... Done
W: Failed to fetch archive.ubuntu.com/ubuntu/dists/quantal/InRelease  
W: Failed to fetch archive.ubuntu.com/ubuntu/dists/quantal-updates/InRelease  
W: Failed to fetch archive.ubuntu.com/ubuntu/dists/quantal-backports/InRelease  
W: Failed to fetch archive.ubuntu.com/ubuntu/dists/quantal-security/InRelease  
W: Failed to fetch archive.ubuntu.com/ubuntu/dists/quantal/Release.gpg  Unable to connect to archive.ubuntu.com:http: [IP: 80]
W: Failed to fetch archive.ubuntu.com/ubuntu/dists/quantal-updates/Release.gpg  Unable to connect to archive.ubuntu.com:http: [IP: 80]
W: Failed to fetch archive.ubuntu.com/ubuntu/dists/quantal-backports/Release.gpg  Unable to connect to archive.ubuntu.com:http: [IP: 80]
W: Failed to fetch archive.ubuntu.com/ubuntu/dists/quantal-security/Release.gpg  Unable to connect to archive.ubuntu.com:http: [IP: 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.

I am using Ubuntu 12.04. This is the command I used after installing Ubuntu from window installer. I am sure my laptop is connected to internet. What can I do now?

  • I removed http:// before all links.. So, they can't be seen as links Oct 29, 2012 at 8:44
  • I didn't upated it.. It's a fresh install using a ubuntu-12.10-desktop-i386.iso file Oct 29, 2012 at 9:05
  • I changed the software source to other near by servers and run the command again,still the same problem is repeating, with the exception archieve.ubuntu.com is replaced with mirror.cse.iitk.ac.in Oct 29, 2012 at 9:09
  • I have an ubuntu server 12.04.1 as the master dns server including dhcpd. in my options file I had only the secondairy dns-server's ip in the allow query list, when I added the same problem was fixed. Though, in the presented detection method (previous answer) I could not ping archive.ubuntu.com.
    – user123585
    Jan 16, 2013 at 4:01

5 Answers 5


As vasa1 pointed out, the server your system is configured to use to download packages for installation is currently down.

What to do when your download mirror is down...

The solution to this problem is to use change it to a different mirror (i.e., a different server).

Option 1: Using Graphical Configuration Utilities

Open Software Sources

Press Alt+F2, type gksu software-properties-gtk, and enter your password. (Alternatively, select Settings... at the lower left corner of the Update Manager, or go to Settings > Repositories in Synaptic).

  • That's for Ubuntu 10.04 LTS, which you are running. In later releases, you can just run software-properties-gtk and when you make changes, PolicyKit will authenticate you.
  • Most people using newer releases have the Software Center and not Synaptic. In the Software Center, you would go to Edit > Software Sources....
  • The Update Manager is unchanged, but in new releases is called the Software Updater.

Change the Download Server

In the Ubuntu Software tab of the Software Sources window, there is a drop-down menu labeled Download from. Select your regional server. For example, I'm in the United States and it looks like this on my 11.10 machine:

Software Sources window showing Server for United States being selected in the drop-down menu.
Software Sources window showing Sever for United States being selected in the "Download from" drop-down menu.

You may see other servers listed in that short list (like the server you currently have set up).

You can use the Main server too but it is almost always considerably slower than using your regional server. (At least in the United States, anyway.)

If you want to use another mirror, you can look through a list of mirrors by clicking Other....

Choose a Download Server dialog in Software Sources, for picking an alternative mirror

Option 2: Manually Editing a Configuration File

Back Up and Open sources.list

Back up your sources.list file and open it in a text editor:

cd /etc/apt
sudo cp sources.list sources.list.old
gksu gedit sources.list
  • If you've already ran the second line, don't do it again, unless you want to overwrite the old backup with a copy of the new configuration.
  • For a text-based editor (not requiring any GUI), replace the third line with sudo nano -w sources.list (or sudo vi sources.list, or sudo -e sources.list).

In the text editor, replace every instance of your old server name with the new server name. For example, you could replace every instance of ubuntuarchive.hnsdc.com with us.archive.ubuntu.com. (Your text editor, whichever you use, will facilitate this--you don't have to manually find each instance and type in the name of the new mirror.)

Save the file, quit the text editor, run sudo apt-get update, and it should work with the new server.

Option 3: Command Line Substitution

sed allows you to write simple (or complicated) scripts that act on a file, one line at a time. So you can issue a single command that goes through sources.list, replacing all the instances of the old server name with the new server name.

First, go into /etc/apt and (unless you did so recently) back up the file:

cd /etc/apt
sudo cp sources.list sources.list.old

Then run sed:

sudo cp sources.list sources.list.tmp
sed 's/ubuntuarchive.hnsdc.com/us.archive.ubuntu.com/' sources.list.tmp | sudo tee sources.list
sudo rm sources.list.tmp
  • For an old server besides ubuntuarchive.hnsdc.com, change that as appropriate.
  • For a new server besides us.archive.ubuntu.com, change that as appropriate.
  • I decided to copy sources.list into a temporary file and use that as sed's input. This is one way to ensure that sed is not overwriting the file while it's still reading it.
  • The sed "script" here is very simple. This explains how substitution works.

But what download servers are there?

There are over 400 registered Ubuntu mirrors for installing and updating software.

These are called archive mirrors. This should not be confused with CD mirrors, where ISO images and related files for installing Ubuntu are stored.

Many servers provide both, and are thus both archive mirrors and CD mirrors. But many are just one of the two.

  • Shouldn't the answer also address "0 upgraded, 3 newly installed, 0 to remove and 21 not upgraded?" In other words, OP will want to do a dist-upgrade?
    – user25656
    Jan 18, 2013 at 2:34
  • @vasa1 There's no reason to think that will still be the case once sudo apt-get update is successfully run. It's based on information about available packages that is out of date. Also, just saying "run apt-get dist-upgrade" wouldn't be a sufficient response to that, as sometimes dist-upgrade does not resolve dependencies in a good way--important packages might end up removed. (Probably not, but it's important to inspect what it proposes to do, rather than running ahead with it.) If this issue persists, I think it would likely be best asked as a separate question. Jan 18, 2013 at 4:14
  • ThnQ .. It worked really well Nov 16, 2013 at 2:36
  • Following option 3, I still get an error: some index files failed to download. Jul 24, 2016 at 20:24
  • It should be noted that this could also happen if the repository no longer exists (permanently), when you update to a new version of Ubuntu, as well as many other reasons.
    – earthmeLon
    Feb 1, 2017 at 20:07

Either the mirror is down or you internet connection has issues (can be temporary).

  • make sure you can ping google DNS and archive.ubuntu.com:

    ping -c3 archive.ubuntu.com
    ping -c3

    Both commands should return 0% packet loss in the statistics line. Else your internet connection is down.

  • If your connection seems fine then it is likely the mirror is down. Try choosing another one close to your location.


Just open synaptic manager, install/reinstall ubuntu-extras-keyring and then (in terminal) type sudo apt-get update.

cheers u'd get out from this error.

  • 9
    This did not work for me. Why would it?
    – pzkpfw
    Apr 14, 2014 at 18:08
  • 1
    sudo apt-get install ubuntu-extras-keyring did not resolve this issue for me.
    – MustModify
    Jan 23, 2019 at 18:05

Go Terminal and follow below steps for solution...

sudo su (login as root)
cd /var/lib/apt/lists/
rm -fr *
cd /etc/apt/sources.list.d/
rm -fr *
cd /etc/apt
sudo cp sources.list sources.list.old
sudo cp sources.list sources.list.tmp
sed 's/ubuntuarchive.hnsdc.com/us.archive.ubuntu.com/' sources.list.tmp | sudo tee sources.list
sudo rm sources.list.tmp*
apt-get clean
apt-get update

Try this. It works for me.

sudo su # login as root
cd /var/lib/apt/lists/
rm -fr *
cd /etc/apt/sources.list.d/
rm -fr *
cd /etc/apt
cp sources.list sources.list.old
cp sources.list sources.list.tmp
sed 's/ubuntuarchive.hnsdc.com/us.archive.ubuntu.com/' sources.list.tmp | tee sources.list
rm sources.list.tmp*
apt-get clean
apt update  

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .