Ubuntu 12.04 won't boot on Samsung Series 9 NP900X3A (ssd hard-drive)

I'm trying to get rid of Windows but I can't boot from USB because the USB slots on the right (USB 3.0) on the Samsung Series 9 doesn't recognize my USB stick.

I tried downloading the USB drivers from the Samsung site and installing them from the Windows partition, but still no luck.

Any ideas how I can get the USB slots working and get rid of Windows?

3 Answers 3


The problem is that Samsung has a fast boot option, hence it ignores changes to the BIOS boot priority. To disable this, use Easy Settings application to get rid of the fast boot option and boot from USB.

  • 1
    This worked. For anyone confused, the "Easy Settings" application is just a replacement for BIOS. So press F2 for setup and that is where you can disable fast boot and choose boot priority. Worked for me.
    – degenerate
    Jun 19, 2014 at 13:05
  • 1
    For anyone wanting to know how to enter the boot menu after disabling fast boot, you have to press the F10 key to enter the boot menu.
    – Busti
    Apr 15, 2019 at 19:11

I also had difficulties to get the boot working. Finally I've got one solution. First, I did the changes recommended before. Next, I read some details about EFI: - http://doc.ubuntu-fr.org/efi (in french) - https://help.ubuntu.com/community/UEFIBooting

By default Samsung support only EFI OS. You can change this on the 'Boot options' screen with SecureBoot (Disabled) AND OS Mode Selection (CSM OS).


From: Linux on the Samsung Series 9 2012 (NP900X3B)

Booting from USB

First step of getting Linux installed is to boot from a USB stick. This took me ages to get working – in particular you must disable “Fast BIOS Mode” in the BIOS setup (it’s on the “Advanced” tab). Then you can alter the boot priority to USB first..

Or, a fairly compete guide:

Installing Ubuntu on the Samsung Series 9

.. This post will describe various components of the setup process that I had diifficulty with. ..

  • Yes, I've seen all of those. I follow the steps there and the ones here: rowntreerob.wordpress.com/2012/07/21/… directly - nothing works. even with fast boot disabled, the right hand legacy USB slots do not work Oct 29, 2012 at 17:10
  • 1
    I'm still not clear on what is stopping the USB ports from working. have you tried manual, to select the specific device? Does the Series-9 recognize any USB device? eg. an external HDD?
    – david6
    Oct 30, 2012 at 8:04
  • 1
    yes, and no it doesn't work. the drivers aren't there, and nothing works for USB, flash drive or otherwise on those ports Nov 1, 2012 at 5:20
  • Only the 'right' of the two USB ports will work for install. May be a BIOS issue. Much more details: ubuntuforums.org/…
    – david6
    Nov 1, 2012 at 8:24
  • yeah I know. there is 1 USB 3.0 slot on the left, and 2 USB 2.0 slots on the right. but neither of the 2.0s work. I disabled fast boot, and still doesn't work. Nov 2, 2012 at 6:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.