Earlier today I downgraded the driver for my nvidia 240 GT from version 310 to version 304 using ubuntus "additional drivers" utility. After the install I rebooted but instead of opening unity and allowing me to login it booted into tty1 instead. After using the "startx" command I got the message, "nvidia: API mismatch: the nvidia kernel module has version 310.14, but this nvidia driver component has version 304.43." What can I do to solve this?

Edit: Solved my own problem by purging all nvidia packaged and reinstalling my drivers.



Same thing happend to me. I did the same as above and it solved it.

For less experienced linux users these are the commands to run:

  1. Purge nvidia related stuff:

    sudo apt-get purge nvidia*

  2. Restart machine:

    sudo shutdown -r now

This will get you machine up and running with X again. Now.. you need to pick a driver from the "Additional Drivers" utility built into the system and by that reinstall the drivers to your machine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.