(Ubuntu 12.04 x64)

After looking at other questions (here and other sites) and trying their respective answers, I am still unable to get the hdmi audio out working.

I have downloaded the recommended hardware drivers for my card (radeon hd 4350), made sure that the card is not muted in alsamixer, and set it as the correct output device in sound settings.

I have also disabled the onboard sound devices in the bios menu. In aplay -l, it shows my hdmi card as hw:0,3

Even after doing sound tests I still cannot hear anything. Any suggestions? Not sure where to go from here, I am fairly new to linux.

  • I found a fix: just enable from BIOS to boot directly in the monitor where you want the hdmi/displayport sound from, it will activate the HDMI or Displayport sound of the monitor. And then you always can switch back and forward during the playback to hdmi and laptop sound, from the Ubuntu sound settings. – Szabi Mar 30 '13 at 19:00

This link solved my problem:

Go to Dashboard home. Find sound properties and change the audio output to HDMI.


My HDMI output audio (SPID) started to work right after the first step from the link above, by just installing the latest drivers from Nvidia. After all, the HDMI port is on the graphics card ;-)

  • Unfortunately, the HDMI card doesn't show up under the sound settings. I can only see it in pulseaudio and when I use the cmd aplay -l – cypwrx Nov 1 '12 at 14:32

This helped me get HDMI audio working on my media server (even though it is an ATI card (last time I make that mistake))

Check out section #8:


  • Thank you for the suggestion. Unfortunately, the only testable device is hw:0,3 (or, I could be reading this wrong... strong possibility) Please see results of aplay -l hdmi:CARD=HDMI,DEV=0 HDA ATI HDMI, HDMI 0 HDMI Audio Output dmix:CARD=HDMI,DEV=3 HDA ATI HDMI, HDMI 0 Direct sample mixing device dsnoop:CARD=HDMI,DEV=3 HDA ATI HDMI, HDMI 0 Direct sample snooping device hw:CARD=HDMI,DEV=3 HDA ATI HDMI, HDMI 0 Direct hardware device without any conversions plughw:CARD=HDMI,DEV=3 HDA ATI HDMI, HDMI 0 Hardware device wi all software conversions – cypwrx Oct 29 '12 at 4:30
  • You may want to edit your question to include the above information as it is nearly impossible to read it in the comment formatting. – Huckle Oct 29 '12 at 16:53
  • I think I am just going to format and try another fresh install. I have tried so many fixes (from other suggestions) that I have a feeling I just need to start fresh again. Thanks for your help. – cypwrx Oct 29 '12 at 17:08
  • Does it work when you are in a live environment? – Huckle Oct 29 '12 at 17:11
  • This is a fresh build that is only running ubuntu. Nothing else installed on the drive. I am not running via cd / usb if that is what you're inferring. Thanks again. – cypwrx Oct 29 '12 at 19:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.