Using Ubuntu 10.04.

Yesterday, I removed the password on one user so that my mother could access my computer. When I tried putting the same password back, I was unable to unlock the user settings to do so using that password.

Now, whenever I try a sudo command in the terminal, it won't accept the password that I know to be correct. There has never been another password on this computer for any user, so there's no chance that I'm just mistaken with what the password is. Caps Lock and Num Lock are both disabled, so it's not that either.

I've been told to use the boot menu to reset it, but I have tried and failed multiple times to open the boot menu. I can't reinstall Grub as I don't know the password. I've been trying for hours to figure out a way to reset/recover the password without having to use the Grub boot menu without any luck.

I've also tried messing with the /etc/default/grub settings to access the grub menu, but I can't change those without the password. I'm basically stuck in a loop of issues and can't figure out how to fix any of this.

Any help would be appreciated.


You don't need to reinstall Grub or change its menu to reset passwords. You can however boot it in single user mode and add the 'init' parameter to change user passwords. Let's forget about it for now.

Do you have any account that has a password set and that you can log in with? If that's the case, are you trying to change a password of a different user than this one?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.