I have a standard account with no password, then in the terminal it aksed for my password to install a program, I tried just ENTER and the adminstrators password but none worked, then I tried to create a password but I can't cause it says that the current password is wrong, but I haven't made a password yet! what's going on? Any ideas?


From my reading of your question it appears that you already have an administrator user on the machine, and you do know that user's password. From that administrator's account you added another user account, without setting a password for it. Now, when you log in as that second non-admin user, you can't install programs because it asks you for a password and you can't give it the password because you haven't set it. Is that right?

If I understood you right, then you need to do the following steps:

  • log in as your original administartor user.

  • in console, type

    sudo passwd myotheruser
  • to give the myotheruser account permissions to install software, you can add it to admin group (again, while logged in as the original administrator user):

    sudo usermod -G admin myotheruser 

After that your myotheruser account will be able to use sudo commands, install software and will have essentially the same privileges as your original administrator account.

  • now when I type sudo passwd myotheruser it says that myotheruser doesn't exist.?!? – Jo Rijo Oct 29 '12 at 11:48
  • Do you literally type "myotheruser" or do you substitute it with the actual username of your other non-admin user account (the one which has no password)? Then you must be making a typo somewhere. To see what the actual username is, type ls /home - it'll give you the list of user's home directories which names by default match usernames. – Sergey Oct 29 '12 at 22:08
  • it was lower case instead of the upper case that the login shows, thx @Sergey. now it seems I have a password and can change it in my account but it still doesn't seem to have an effect. it still doesn't ask me a password to login. + now I don't remember what I wanted to install from the terminal anymore anyway I can use the admin account to do that, so I personally don't have a problem anymore given that I don't want a password to login but it is still a problem for who does I suppose. anyway thx – Jo Rijo Oct 31 '12 at 10:41
  • @JoRijo: "automatic" login without a password is controlled by a setting in the control panel. You can have a password and still be able to login automatically. In fact, having NO password set would not allow you to log in at all. – Sergey Oct 31 '12 at 22:08
  • automatic login is not the same as login without need to give password. I have automatic login off always but now that I have a password it still doesn't ask me for it to login. – Jo Rijo Nov 1 '12 at 1:51

I hope you must have entered a password during installation for sure, if you dont remember and you have access to any other user account with administrator privileges, you can set password for this user from that account. For that you can use terminal,

Login to other account

ctrl+alt+t brings terminal screen type

sudo passwd rohith

here instead of rohith give user name of locked account for which you have lost password.

now you have to enter current user password and then you can enter new password for the other user. and then login to that account with that password.

Second method is by logging into debug mode from grub, and following same command as above

  • just tried that but also doesn't work. terminal says password for Jo Rijo doesn't exist. which is correct. – Jo Rijo Oct 28 '12 at 19:50

It seems that the root (administrator) user doesn't have a password. Just open a Terminal (Dash >> Terminal) and enter the following command:

sudo passwd root

And then enter the password twice. If it doesn't work (sudo shouldn't work if root hasn't a password) try logging in as root on a separated TTY. Please, read all the answer before continuing! Press CTRL+ALT+F2 and enter root. When it asks you for a password, just press enter. Then enter the following command:

passwd root

And enter the password twice. Maybe it'll work!

For going back to the graphical interface (the desktop) just press CTRL+ALT+F7 or CTRL+ALT+F8.

  • Enabling password for the root account is not recommended. Also, the idea that you can log in as root by providing an empty password is... err... funny :) – Sergey Oct 28 '12 at 23:30
  • And how do you login as root without password? – Addison Montgomery Oct 29 '12 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.