I have installed Matlab 2012a on ubuntu 12.04, while providing the licence I find the following error:

Could not complete Activation because the License File could not be written to disk.  
You might not have write permission on the License File or the folder.
  See your System Administrator for assistance. The specific error message text is: 
  (No such file or directory).

In this case I would try creating the directory the license should be written to. Open a terinal with Alt-Ctrl-T and enter:

sudo mkdir -p /usr/local/MATLAB/R2012a/licenses
sudo chmod a+rw  /usr/local/MATLAB/R2012a/licenses

The first two of these may already exist, and if so that's OK, just go on. Then try the license install again.

|improve this answer|||||
  • You only need sudo mkdir -p /usr/local/MATLAB/R2012a/licenses which will create parent folders if they are absent. – Adrian Oct 28 '12 at 18:58
  • @John tried. It still fails. – MalTec Oct 29 '12 at 5:30
  • @MalTec Please mark it as unaccepted so that your question still gets attention from the community. What happened when you tried this? (A permission problem perhaps?) If so are you running privileged when you try to activate the license? If not we will need to set corresponding privileges on the directory. – John S Gruber Oct 29 '12 at 13:45
  • @Adrian Changed the answer to incorporate your suggestion. Thanks! – John S Gruber Oct 29 '12 at 13:47
  • @JohnSGruber the answer provided by both of u(@Adrian) was an essential step towards achieving it. However I had to use chmod from root to allow write permission to normal user. Would be nice if u can incorporate that as well. – MalTec Oct 29 '12 at 19:53

gksudo ./activate_matlab.sh

This is a graphical overlay for sudo and will solve the problem.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.