I'm using Ubuntu 12.10 with an ATI Radeon HD5670 card.

I currently have the open source xorg-edgers driver. I've been using this driver interchangeably with the Radeon open source driver since fglrx seems to give me a lot of freezes. So I can't really use proprietary drivers, the Radeon driver seems to be stable for me, the resolution is the only problem.

The resolution is stuck at 1024x768, where my monitor's native resolution is 1366x768. How do I enable that resolution? Going to System Settings > Display only gives me 800x600 and 1024x768 by the way.

And just another question, how do I know if xorg-edgers driver is enabled? When I run sudo lshw -c video, I still see the radeon driver.

configuration: driver=radeon latency=0

Thanks a lot in advance!


Running xrandr gave me this:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
DVI-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm

So following the guide, I typed in the following:

cvt 1366 768 60

xrandr --newmode "1366x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

xrandr now gives me this line:

1366x768_60.00 (0x178)   85.2MHz

But I'm still not able to execute the add command xrandr --add-mode DVI-0 1366x768, it just shows me the usage page for xrandr.

  • Try instaling proprietary drivers. You can do this from SystemSettings>SoftwareSources or by installing fglrx package. Oct 28, 2012 at 16:45
  • @rafalcieslak I've already tried using proprietary drivers, but as I've mentioned, they do not work well for me (freezes/hangs/glitches).
    – gerky
    Oct 28, 2012 at 16:53

1 Answer 1


If I'm correct in understanding your question: you are using the radeon driver in the xserver-xorg-video-ati package from the xorg-edgers PPA. If this is the case, then you are still using the radeon driver (as you should be).

You can add a new video mode (resolution) by doing the following. Use $ xrandr to determine the video output in use. Then, # xrandr --addmode [OUTPUT] [MODE]. For example, I would put # xrandr --addmode LVDS1 1920x1080. This is taken from here.

EDIT: For the sake of completeness, a new mode needed to be created before adding the mode to the device. The mode then needs to be switched to. All of this is covered in the link.

  • The version of radeon driver you use is listed at the bottom of $ man radeon.
    – astex
    Oct 31, 2012 at 13:52
  • the xrandr --add-mode command still does not work for me. Am I missing something? I've updated the question with more details. Thanks.
    – gerky
    Oct 31, 2012 at 14:20
  • You have successfully added the mode. Now you need to associate is with the card via --add-mode (e.g # xrandr --add-mode DVI-0 1366x768_60.00) and switch to it with --output and --mode (e.g # xrandr --output LVDS1 --mode 1366x768_60.00). Note that you need superuser privileges to switch modes.
    – astex
    Oct 31, 2012 at 14:24
  • 1
    Unfortunately xrandr --output DVI-0 --mode 1366x768_60.00 gives me xrandr: cannot find mode 1366x768_60.00
    – gerky
    Oct 31, 2012 at 14:29
  • I looked through my xrandr outputs and there is nothing with a dash. Are you sure it is DVI-0 and not DVI0?
    – astex
    Oct 31, 2012 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.