I upgraded to 12.10 today and noticed that the torrents I'm seeding went to 0% so I have to download it again. I checked Deluge's preferences and found that after the upgrade the downloads pathway went to 'juno' folder when it should be on my 'Torrent Downloads'. I had trouble resorting it back to 'Torrent Downloads' because it kept going back to 'juno' after clicking Apply or OK although after several tries it's now set to 'Torrent Downloads'.Deluge Preferences

I checked a single torrent and found in the options that its path is towards 'media'. I'd like to think this is towards my external hard drive which I direct all my torrent downloads to. Individual torrent option

All my completed downloads went back to 0%. I tried rebooting my laptop but unlike before where Deluge automatically re-checks completed files, now it's downloading like it's a newly added torrent.

Can I get back the '100% completed' status to some of torrents again?

ETA: My torrent files are located in my hard drive but I direct my torrent downloads to my external hard drive. I didn't move my torrent files folder in my hard drive before or after my 12.10 upgrade.

  • Have you tried right-clicking and selecting the Force Recheck option? – nanofarad Oct 28 '12 at 13:28
  • When I click Force Recheck its status changes to Error. – onvas Oct 28 '12 at 13:32
  • ...and what was the error message? – Cas Oct 30 '12 at 0:18

I have a dual boot system so I have NTFS partitions. This is where I keep my downloaded torrents. I noticed that the mount points of those partitions have changed in 12.10! The path now contains the user name.

  • Old path: /media/volume
  • New path: /media/username/volume

Deluge keeps looking for the torrents in the old folder, but obviously can't find them, and tells you an error. The error message also can be found, it is on the 'Files' tab:

Status: Permission denied: /media/volume/...

So it's rather a Unity/Ubuntu/GTK error than a Deluge one.

I also experience difficulties with setting the download locations or using the 'Move Storage' option in Deluge. I noticed it succeeds if in the file selection dialog I click the directory name only once (not changing to it by double-clicking, only selecting it by single-click).

Manually re-adding a torrent as explained above fixes the path problems.


My experimenting found me a solution. I right clicked on a torrent then selected Remove Torrent > Remove Torrent. Then I manually add the torrent file I just deleted and Deluge would automatically re-check my completed torrent until it would seed again or if incomplete, would re-check the percentage completed and restart the download from that point on.

Remove selected torrent option

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.