UPDATE: Since this question has got many views, I just want to add that from Ubuntu 13.04 onwards, proprietary drivers installed perfectly on my MacBook. Versions of Ubuntu prior to 13.04 will have problems

I recently upgraded to 12.10 and was just checking for proprietary drivers to be installed. I found this in software sources

Additional Drivers

When I enabled Nvidia binary Xorg driver, unity disappears along with the launcher and everything. I just have the wallpaper. I did manage to open the terminal and open software sources and select the nouveau display driver which fixed it.

Question is how to enable NVIDIA binary Xorg driver and have everything working?

Hardware: Apple MacBook Pro 9,1 Mid 2012 15 inch non-retina. NVIDIA GeForce GT650M

EDIT: I tried the solution here. And now, when I boot into Ubuntu, I get a blinking cursor. That's all! No tty1, nothing. help !!

EDIT 2: I inserted the Live USB and re installed Ubuntu without formatting the partition. At least, I didn't lose my files, but all softwares are gone. And the output of

lspci -vnn | grep '\''[030[02]]'

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:0fd5] (rev a1) (prog-if 00 [VGA controller])

EDIT 3: So, I was checking the link which Shrinivas gave, namely this one http://www.dedoimedo.com/computers/ubuntu-quetzal-nvidia.html and it doesn't work for me. Specifically, where he says to run the command modprobe nvidia_current, I get the output

FATAL: Error inserting nvidia_current (/lib/modules/3.5.0-22-generic/updates/dkms/nvidia_current.ko): Operation not permitted

So, what's the problem? To reiterate, I'm using Ubuntu on an Apple MacBook Pro Mid 2012 15 inch non retina 8GB RAM with NVIDIA GeForce GT650M

  • Possible duplicate of : Nvidia driver doesn't work in 12.10 – NickTux Oct 28 '12 at 10:22
  • I followed the steps there and now Ubuntu doesn't boot!! I just get a blinking cursor on boot! Please help – pratnala Oct 28 '12 at 10:59
  • can you please add the output of: lspci -vnn | grep '\''[030[02]]' – beanaroo Oct 28 '12 at 11:36
  • done. pls see edits – pratnala Oct 28 '12 at 11:40

Same problem here with new kernel update to 3.5.0-21 You can run the terminal from a F##! up unity by keyboard shortcut ctrl+alt+t Then you can run the command software-center to launch the software center or google-chrome to launch the chrome internet browser (better than anything ^^) Install linux-headers-3.5.0-21-generic from software-center (I'm on x64) download the 310.19 version of the driver on Nvidia's website


login with user + psw

cd Downloads (or whatever path you downloaded your nvidia####.run file)

sudo service lightdm stop

sudo sh nvidia.run (I renamed the nvidia install file to "nvidia.run" when downloading) I think I did say yes afterward to everything in the installation process

sudo reboot

Hope it helps

This is my output to your command in the terminal:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF106 [GeForce GTS 450] [10de:0dc4] (rev a1) (prog-if 00 [VGA controller])

Actually it seems that nvidia drivers don't fit in ubuntu 12.10. I installed from PPA

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

This PPA will install all the missing packages (dkms fakeroot linux-source linux-headers-generic linux-headers 3.5.0-17-generic...). I did it yesterday after several attempts with the proprietary drivers and, for now, it works pretty well. If you do not find other solution, give this one a try. Bye!

  • Several attempts? What happened each time? – pratnala Oct 29 '12 at 2:35
  • I had to use nvidia-experimental 310.14 to get nvidia blobs to work on my MacBookPro9,1. But after sleeping/resume, I get a black screen. I did find a fix, but it seemed complex and so I stayed with nouveau. – philcolbourn Nov 3 '12 at 13:45
  • Even with nouveau, I can't resume after sleep. I have to shut down everytime. Are you able to do it? – pratnala Nov 5 '12 at 5:50
  • @beppe all the packages you mentioned were installed. Doesn't help. – pratnala Dec 13 '12 at 17:43
  • @pratnala: Yes, my macbook pro 9,1 sleeps nicely with nouveau. Linux rex 3.7.5-030705-generic #201301280206 SMP Mon Jan 28 07:07:29 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux. I can not boot using grub: instead I use Apple's EFI boot (hold down Option when power on) and select 'Windows' or Linux partition. – philcolbourn Apr 16 '13 at 5:35

Install the linux sources and headers. These are required to build the driver.

sudo apt-get install linux-source linux-headers-3.5.0-17-generic

Then unistall any nvidia drivers you have installed.

sudo apt-get remove nvidia-current

Then reinstall the nvidia driver

sudo apt-get install nvidia-current

Then restart the computer

sudo shutdown -r now

It should now boot up using the nvidia drivers.

  • I did this and ubuntu won't boot. I just got a blinking cursor. No tty1, 2 or anything. – pratnala Nov 3 '12 at 9:59
  • 1
    If grub's menu appears, select 2nd option - something like other or rescue - and boot to a shell or try safe-mode. Then remove nvidia packages and try again. – philcolbourn Nov 3 '12 at 13:51
  • @philcolbourn It got stuck in recovery too – pratnala Dec 15 '12 at 14:15

Downloading the Drivers directly from NVidia and building it worked for me.

  • 1
    This would be a good answer if you can describe what you did and how you would 'build' the driver. – fossfreedom Dec 15 '12 at 12:14
  • Can you explain the process in detail? I am kind of an Ubuntu noob – pratnala Dec 15 '12 at 13:04

Please see this:


He gives a detailed explanation for installing proprietary nVidia drivers.

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – fossfreedom Dec 15 '12 at 21:30
  • This still doesn't work. See my edited question please. – pratnala Jan 18 '13 at 6:16

It seems sleep process is much more complicated in such cases..try hibernate against that.as I found it better option or alternative solution.

see this if you prefer to hibernate

up vote 0 down vote accepted

NVIDIA drivers install without a fuss on MacBooks on Ubuntu 13.04 and above.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.