I have an Asus UX21A, and I'm pleased to discover that almost all the hardware functions and features work perfectly with Ubuntu 12.10.

The only thing that is not working straight "out of the box" are the brightness keys. In theory, the screen brightness can be adjusted downward by pressing fn+f5, and adjusted upward by pressing fn+f6.

Is there a way I can connect the monitor brightness settings to these function keys?

  • Did you try the kernel parameter acpi_osi= in grub ? – NickTux Oct 28 '12 at 10:32
  • @NikTh: I just tried GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor", but it did not change anything. – Questioner Oct 28 '12 at 11:19
  • Have you also tried changing the desktop. Try the gnome Destkop. – Olu Smith Sep 8 '14 at 5:17

According to the Zenbook Prime community page, the answer is "yes", with a caveat. It looks like the problem will be fixed in a 3.7.x version of the kernel (see this bug), but still exists in 3.5.x (i.e. Ubuntu 12.10).

For now, you can try applying this patch to the 3.5.x kernel. For instructions on building the kernel and applying patches, see here. Again, according to the Zenbook Prime community page the patch is imperfect. The brightness-down key works fine, but the brightness-up key imposes an ~2 second delay before other hotkey presses are registered.

The community page also lists a couple of workarounds that involve the xrandr command. The second workaround involves a custom script that is then mapped to Ctrl+Shift+F5/F6. You could, of course change the keymapping to anything you like (say just F5 or just F6, for example).

  • 1
    This problem has not been fixed yet in the 3.8.0 kernel. – Marco Lackovic Apr 25 '13 at 15:32
  • This problem has not been fixed yet in the 3.16.x kernel on Ubuntu 14.10 – webdevbyjoss Dec 13 '14 at 0:03
  • 4.0.0 kernel - problem persists – Dfr Jul 29 '15 at 17:44

I can confirm the brightness keys don't work on an N56VJ either. I run xev and it shows absolutely nothing when fn + f5 or fn + f6 are pressed. The fn key that turns the backlight off completely does work, the system dialog to adjust backlight brightness works, and "echo 5 > /sys/class/backlight/brightness" does set the light to 50 percent.. So the procedure to set the backlight is functioning properly, the issue is getting a valid keypress event out of the function keys.


Although I am on Mint Nadia, my research should be helpfull: First of all you should know that if the grub tweak did not work and if in ubuntu you have no keycode on pressing Fn+F5 or Fn+F6 those keys will be suported from 3.7 kernel version (as I read somewhere). My case is this: those combinations just don't exist under ubuntu or mint (tried both), instead all other Fn combinations work properly or at least they generate a code for the combination (in easystroke, when adding new action, selecting key, then pressing desired Fn combination you get for example XF86WebCam). My notebook is Asus K55VD with I7 processor and nvidia 610m.

I've managed to do a workaround with xdotool and xbindkeys.

The main ideea for the workaround to work is to actually have other Fn combinations, not working by default in your distro and void key combinations like Ctrl + Key, Alt + Key (once you press Ctrl, for example no other key has effect).

Xdotool is used to emulate a virtual key - xdotool key XF86MonBrightnessUp for increasing brightness emulates XF86MonBrightnessUp and xdotool key XF86MonBrightnessDown for lowering brightness(emulates XF86MonBrightnessDown, and if you use Ctrl + <KEY> command, Ctrl won't let XF86MonBrightnessDown/Up to work.

There is a workaround for this too (the use of "Release" key modifier in xbindkeys and creating scripts for both commands including some delay) but it will give you hard time with your brightness: you will have to try the combination a few times before succeeding once, and I mean emulating one movement of the brightness slider (on Asus there are 10 before reaching bottom).

So how I did it: 1. install xbindkeys 2. install xdotool 2. "xbindkeys" in terminal to start it 3. "xbindkeys --defaults > $HOME/.xbindkeysrc" in terminal to generate the file where your keybinds will be. 4. open ".xbindkeysrc" from /home/user directory. There you will see some default examples. Either delete them or comment them with #. 5. for Asus add lines like this:

xdotool key XF86MonBrightnessUp XF86WebCam

xdotool key XF86MonBrightnessDown XF86Launch1

XF86Launch1 is Fn+c and XF86WebCam is Fn+v and they are close to each other, therefor proper. Save, then end or kill xbindkeys (from System Monitor for ex) , then start xbindkeys (from terminal for ex).

They work for me, but not continuesly - every XF86WebCam results in one level brightness up, then holding Fn I have to press again on V and so on. You will not have this luxury if you use a standard combination (assuming they work). You will have to release both keys, then press them again, not getting quick result. I tried using Fn + Arrow Up and Fn + Arrow Down. The first didn't work, the second worked, so i could only change brightness down (or up).

for other notebooks: kind of the same thing but you have to test you own keys,

There is a way without xdotool: install xbindkeys, install xbacklight, generate .xbindkeysrc, and edit it with this:

xbacklight -dec 10

Control + F5

xbacklight -inc 10

 Control + F6

This time you can use modifiers combinations (there is no virtual key generated), but brightness doesn't change that smoothly, and if you keep pressing the combination, in System Monitor you will see multiple xbacklight instances. It's continuous, but it often seems, (if you are not patient) that brightness flickers (from bright to brighter, then from bright to less brighter even though you want only one thing) until you release the keys. It also doesn't show the brightness applet (with the slider), like in the other case.

OK. That's all. Have fun!

  • now i see that the command and key combination are both on the same row, They may work(didn't try) but by default should be placed one under the other – cyberalex4life Jan 19 '13 at 21:35

Have u tried pasting in grub file the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor"

then update grub and reboot!



Just map the following commands to a keyboard shortcut

brightness `expr \`brightness\` + 10 
brightness `expr \`brightness\` - 10 

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.