268

I am working on Ubuntu 12.04 64bit.

I want to add "Open terminal here" to Nautilus context or right-click menu but it tries to download 32bit version from Internet.

  • 1
    I really don't understand the question. Could you reformulate and explain it differently? – Hanynowsky Oct 28 '12 at 2:34
  • 3
    @Hanynowsky its a feature found in Xubuntu/xfce. – Suhaib Oct 28 '12 at 3:42
  • It's actually a feature that plugs into nautilus, so ordinary Ubuntu works, as well as many others that use nautilus. – tudor May 8 '13 at 2:10
  • the feature is also found in cinnamon – phuclv Nov 4 '16 at 3:01
  • The solution in some of the answers is to install a package. There is no longer a need to install a package because this feature seems to be already present in 16.04. – H2ONaCl Dec 7 '16 at 22:59
350

You have to install the nautilus-open-terminal package from the universe repositories for Ubuntu versions up to Ubuntu 15.04:

sudo apt-get install nautilus-open-terminal

If you want to install it with apturl, use this URL: apt://nautilus-open-terminal

Then:

nautilus -q  

In order to restart Nautilus

Result

In Ubuntu 15.10, the functionality is already included in nautilus!

  • 2
    I notice that in 13.04 raring ringtail it has disappeared from the "Files" menu and is now only available in the right-click menu. :-( – tudor May 8 '13 at 2:09
  • 1
    Any idea on how to make it use the normal terminal settings? The terminal it opened didn't have the normal colors and settings. – snapfractalpop Dec 3 '13 at 18:06
  • @snapfractalpop Do you verify that the terminal it opens is the one you expected? There is not one terminal program only on an Ubuntu install (at least gnome-terminal and xterm). – air-dex Dec 4 '13 at 1:57
  • 6
    Works for 14.04 too. – Thorbjørn Ravn Andersen May 1 '14 at 7:26
  • 7
    In 16.04 there is no nautilus-open-terminal package. Use nautilus-actions instead. – nachtigall Sep 10 '16 at 4:32
42

nautilus-open-terminal and nautilus-actions packages are available in Universe repository of Ubuntu 14.04. So run the below commands to enable universe repository and also to install above mentioned packages.

sudo add-apt-repository universe
sudo apt-get update
sudo apt-get install nautilus-open-terminal
sudo apt-get install nautilus-actions

Finally run nautilus -q command to quit nautilus.Now you can be able to see Open in terminal option on right-clicking.

  • Hadn't had a chance to try it on 14.04 yet. But I just did and it worked. :) Thanks again! – Benjamin Oakes Apr 21 '14 at 1:39
  • Is the universe repository enabled per default? I did not have add it manually. – king_julien Jun 23 '14 at 5:41
  • 2
    it isn't enabled by default. You have to add it manually. – Avinash Raj Jun 23 '14 at 5:48
  • 1
    +1 for "sudo add-apt-repository universe" which I was looking for :) – Kozuch Aug 12 '14 at 13:45
11

Here is my script to open terminal in the current directory,

I built my own after the open-terminal plugin stopped working for me

#!/bin/bash
##################################
# A nautilus script to open gnome-terminal in the current directory
# place in ~/.gnome2/nautilus-scripts
##################################
#                                       Remove file:// from CURRENT_URI
gnome-terminal --working-directory=`echo "$NAUTILUS_SCRIPT_CURRENT_URI" | cut -c 8-`

PS: Here is some bonus info

Assigning a shortcut to the script

  • Add executable script to ~/.gnome2/nautilus-scripts
  • Wait some time - nautilus regenerates accels file
  • Edit file ~/.gnome2/accels/nautilus

  • Find line similar to this one:

; (gtk_accel_path "<Actions>/ScriptsGroup/script_file:\\s\\s\\shome\\sgautam\\s.gnome2\\snautilus-scripts\\sopen-terminal" "")

  • Remove comment (semicolon) and specify shortcut like this:

(gtk_accel_path "<Actions>/ScriptsGroup/script_file:\\s\\s\\shome\\sgautam\\s.gnome2\\snautilus-scripts\\sopen-terminal" "<Primary><Shift>t")

  • Save file.
  • Logout - login.
  • Will it work on nautilus-GTK3 ? – Tachyons Feb 3 '13 at 14:22
  • Not sure, I am using it on plain ubuntu 12.04 x64, give it a shot . – Gautam Feb 3 '13 at 14:42
  • In 14.04, Gnome 13.12, the script works, but the shortcut assignment method does not. – Rasmus Jun 17 '14 at 11:08
5

I have just installed Ubuntu 14.04 Desktop edition today 07-18-2014, and all I had to do to get the command line option in Nautilus was the following in a terminal:

sudo apt-get install nautilus-open-terminal
nautilus -q
  • 5
    sorry ,how it is different from accepted answer? – Ravan Oct 6 '15 at 1:41
  • IIRC a lot of different solutions were posted, some speaking of different ubuntu versions requiring different methods -- so I posted my experience on my version at the time. – bazz Oct 7 '15 at 3:28
  • I appreciate you-don't mind-this post came on review,that is the only reason I posted the comment – Ravan Oct 7 '15 at 3:32
2

You'll need to install nautilus-admin (make sure to install the additional files) to have the right click option and others as well, since nautilus-open-terminal is no longer maintained.

1

I used @Gautam's solution until I found it will not work (I mean a script itself) if path contains non-ascii characters because it's URL encoded.

Here is my little fix which is working at least for me. So, the script should look like this:

#!/usr/bin/gnome-terminal

According to gnome-terminal docs, when you execute this:

cd path/to/dir
gnome-terminal

gnome-terminal will use path/to/dir as working directory, which explains why that script works.

0

Do

sudo apt-get update

and try again.

Or

cd /tmp  
wget http://mirrors.kernel.org/ubuntu/pool/universe/n/nautilus-open-terminal/nautilus-open-terminal_0.20-1_amd64.deb
sudo dpkg -i nautilus*deb
sudo apt-get install -f
0

If you are using Ubuntu 18.04 or newer:

sudo apt install nautilus-admin 
  • This is not an addon to open a terminal in the current directory, but to open a nautilus window with root permissions or edit a file with root permissions. The accepted answer is still valid for 18.04. You may want to delete your answer. – vanadium Apr 2 at 14:14
-2

This link provides the best working solution for adding the feature "Open terminal here" as context command menu for a folder.

http://www.n00bsonubuntu.net/content/add-open-terminal-here-to-file-menu-ubuntu-14-04/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.