I seem to have a problem similar to many but I didn't manage to get it solved:

  • have a Lenovo N581 with an NVIDIA GeForce 610M
  • have just installed a fresh Ubuntu 12.10 64 bits, + KDE
  • and am trying to have my NVIDIA card work.

Have tried all workarounds posted: purge nvidia, install kernel source/headers and then reinstall nvidia-current-updates (or just nvidia-current), do "sudo nvidia-xconfig".

It does create a xorg.conf but does not much (no Module Section by the way). The result is that my system (jokey) tells me that the driver is there but not in use and I only get a 640x480 resolution. If I try to launch nvidia-settings it does indeed tell me that the nvidia driver is not used.

I do all this under kde but I guess it does matter at this stage.

Any hint of how to resolve this? I feel stuck and cannot use any of the acceleration which is partly why I got that laptop in the first place...

thanks for any help/advise you may provide!

  • I asked the same question a week ago, and it was closed as exact duplicate of this one. Laptop: GeForce GT 330M, desktop: GeForce 9600GT. Both manifest the exact same behaviour with Quantal 64 bit, both Unity and Gnome Shell (permanently in fallback mode + some ridiculously low resolution). So far the only workaround that worked for me is called Windows. – mingos Nov 5 '12 at 10:54
  • I just had the same problem on 12.04 (GT750M with Intel HD3000). GUI doesn´t start anymore, tried a lot of things, i get IO errors all the time in command line (failed to Read FPDMA queued etc. – Yves Sep 7 '13 at 15:33

The working solution can be found at the link below:

  • Make sure to have the system up to date first (so the new kernel is applied first).


It allows nVidia driver deb to compile the kernel boot module as it's installing, but it fails without the correct packages (that are not included by default and not a dependency of the nVidia drivers deb/package directly). After I did the above fix I had full resolution on Ubuntu 12.10, Mint v14 and Kubuntu 12.10.

| improve this answer | |

The modules should install and work to some extent. There may be other problems such as performance or corruption, but that's another issue. You do have to reboot, or at least re-start X for the module to take effect. Are you being impatient and not giving it a chance to load the drivers? To recap the procedure:

sudo apt-get install nvidia-current


sudo apt-get install nvidia-current-updates


sudo reboot

or just log out and log back in again to re-start X. (Given your problems, maybe a fresh boot wouldn't hurt, though theoretically a re-start of X is all that is required.)

Next try


If the driver is working well enough for you to see, it should load the settings program. Having a laptop default to some really low-res mode is darned odd. It should not be happening, even (especially) with the nouveau driver.

I take it you installed Ubuntu and then added KDE? Maybe just try the default Unity for a while. I don't use KDE so I'm not aware of any specific problems with it that might be making your job harder. Maybe get rid of /etc/X11/xorg.conf and start fresh.

| improve this answer | |
  • 2
    thanks a lot. To be very clear: not being impatient here but I spent one full afternoon trying to redo all this from scratch (purge, reinstall sources/headers/nvidia, reboot, etc). When I do the nvidia-settings steps (and after doing all of the rest) it tells me I am not using the nvidia driver. And when I open jockey it tells me the driver is activated but NOT in use. I also did remove xorg.conf many times : this basically just turn things back to the original setup (with the normal resolution). When I recreate an xorg.conf (nvidia-xconfig) --> back to 640x480 and same story (see above). – user1293231 Oct 28 '12 at 10:21

I had the same problem with my Lenovo G780... Could not understand why the nvidia-drivers weren't working.

THEN... I discovered the notebook relies on Optimus technology. Hybrid graphics where the nvidia chip is "piggybacked" onto the intel graphics. Useful for saving a lot of power, the nvidia only comes into play when using graphics intensive programs.

This is a great feature... when you are running Windows. Linux has yet to catch up but there are open source measures being taken.

The project is called Bumblebee. It works for me so far.

I wish I had known this before. I'm not sure if this applies to your scenario but from what I've read, the technology is used greatly by Sandy/Ivy bridge chipsets.

You can check for Optimus by running the following command:

lspci -vnn | grep '\''[030[02]\]'

If it outputs two lines, you're likely having an Optimus laptop.

| improve this answer | |
  • thanks for the post! Will have a look at Bumblebee then and try it!! Please let me know if there is any trick to make this work: the web page states that it is just a matter of installing it and giving permissions. Will report here as a comment as soon as I have tried it. Thanks for the tip! – user1293231 Oct 28 '12 at 10:24
  • Be sure to check out the wiki @ github.com/Bumblebee-Project/Bumblebee/wiki Good Luck! – beanaroo Oct 28 '12 at 11:02
  • Thanks. Almost there but now I face the "Cannot access secondary GPU - error... Failed to initiliase the NVIDIA GPU at PCI:1:1:0. So I need to find a way forward. Looked at the git troubleshooting, checked ACPI, no problem there. Also kern.log has a bbswitch issue (failed to evaluate_DSM..) and a NVRM failure (failed to copy vbios to system memory). Will search... Any hint welcome – user1293231 Oct 28 '12 at 13:06
  • Ok. No luck. Went through many posts and couldn't find something useful. I still get the same error message. Lots of posts but nothing which works. I see there is a hack for lenovo's for bbswitch. not sure I want to use that. – user1293231 Oct 28 '12 at 14:09
  • It's worth noting that another option is to just disable Optimus in the BIOS. I did that and everything worked instantly (of course, without the battery savings, but I'm mostly stationary these days) – MalcolmOcean Jan 16 '13 at 9:39

I ran into this problem on release day and running sudo apt-get install linux-source linux-headers-$(uname -r) worked, at the time, and until the update this past week (Nov. 4) broke it again.


sudo apt-get remove --purge nvidia-current linux-source linux-headers-*
sudo apt-get autoremove --purge
sudo apt-get update
sudo apt-get install nvidia-current

worked this time.

I assume that at release nvidia-current wasn't pulling the headers and sources as dependencies and now that it is, it somehow confused it. Hopefully this is solved for here on out.

| improve this answer | |
  • Doesn't work for me, I still get the missing source message, no module built. – levesque Feb 2 '13 at 23:35

to install nvidia gt 610m driver for ubuntu 12.10 :

first remove nvidai driver :

sudo apt-get remove nvidia-current && sudo apt-get remove nvidia-current-update

Then :

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update && sudo apt-get install nvidia-current nvidia-settings

For Ubuntu 12.04 or earlier :

sudo apt-get remove nvidia-current && sudo apt-get remove nvidia-current-update

Then :

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get install nvidia-current nvidia-settings

Good luck

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.