I installed lubuntu 12.10 on Dell Idea-pad 10-2. This model has Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01) as wireless module.

I tried to use driver from both firmware-b43-lpphy-installer and bcmwl-kernel-source and both also worked fine when connect to the internet. However, I cannot connect to the point that use WPA2 enterprise. It's continuing ask for the password all the time and not connected. Could you please suggest any idea to solve this problem? Thanks in advance.

result from sudo lshw -class network:

   description: Wireless interface  
   product: BCM4312 802.11b/g LP-PHY  
   vendor: Broadcom Corporation  
   physical id: 0  
   bus info: pci@0000:02:00.0  
   logical name: eth1  
   version: 01  
   serial: 00:25:56:b9:92:21  
   width: 64 bits  
   clock: 33MHz  
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless  
   configuration: broadcast=yes driver=wl0 driverversion= ip= latency=0 multicast=yes wireless=IEEE 802.11bg  
   resources: irq:17 memory:96100000-96103fff  

from rfkill list all:

0: ideapad_wlan: Wireless LAN  
Soft blocked: no  
Hard blocked: no  
1: ideapad_bluetooth: Bluetooth  
Soft blocked: no  
Hard blocked: no  
2: brcmwl-0: Wireless LAN  
Soft blocked: no  
Hard blocked: no  
3: hci0: Bluetooth  
Soft blocked: no  
Hard blocked: no  

from lsmod | grep wl:

wl                   2442848  0   
lib80211               14040  2 lib80211_crypt_tkip,wl  

from lspci|grep Network:

02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
  • I am also having this problem with my HP Compag nx-6110 notebook using a Broadcom adapter. I don't have the specifics on that adapter though. I'm using Wicd as my network manager. – Steve Jorgensen Jan 19 '13 at 2:36

I want to confirm this issue since I installed Ubuntu 12.10 with the bcm4312 firmware wifi radio, B43 driver and WPA2 encryption.

I have a Dell Studio 1725 which has built-in Broadcom BCM4312 802.11b/g LP-PHY (rev 01) wifi radio. It will not connect to an Access Point using WPA2 encryption only, WPA/WPA2 mixed mode works fine. I use the current 3.7 Mainline Kernel.

I have been forced to use a ralink USB wifi radio to connect to my WPA2 AP.

$ lsmod | grep b43:
b43                   387883  0
mac80211              569499  4 rt2800lib,rt2x00usb,rt2x00lib,b43
cfg80211              217733  3 rt2x00lib,b43,mac80211
bcma                   40258  1 b43
ssb                    52833  1 b43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.