Possible Duplicate:
How do I fix the GPG error “NO_PUBKEY”?

after sudo apt-get update I get this error:

W: GPG error: http://archive.hivemind.me all Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3C962022012520A0

marked as duplicate by Jorge Castro, user76204, fossfreedom Dec 10 '12 at 17:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Hi! I tried, but no success, look: .... $sudo apt-key adv --keyserver archive.hivemind.me --recv-keys 3C962022012520A0 Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver archive.hivemind.me --recv-keys 3C962022012520A0 gpg: requesting key 012520A0 from hkp server archive.hivemind.me ?: archive.hivemind.me: Connection refused gpgkeys: HTTP fetch error 7: couldn't connect: Connection refused gpg: no valid Open – Oleksa Feb 16 '11 at 14:30
  • The website appears to be either down or misconfigured, I can't get to it either. – Jorge Castro Feb 16 '11 at 14:30
  • You can check this SO thread for solution. Link to related site – Aniket Thakur Oct 6 '16 at 3:43

Run the following in your terminal,

 sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3C962022012520A0 
 sudo apt-get update

References: How do I fix the GPG error "NO_PUBKEY"?

You need to replace the key (3C962022...) with the one that is displayed in the error message in the terminal.

  • It works for me. – Fahim Babar Patel Nov 13 '16 at 7:08
  • Me too! I'll have to read up on this. – bd1251252 Mar 24 '17 at 6:39
  • How do you achieve this on OSX? – zero_cool Oct 22 '17 at 21:06
  • 1
    If you get a keyserver timed out error, do sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3C962022012520A0 – arjun Nov 12 '17 at 15:09
  • @arjun I received a gpg: keyserver receive failed: Server indicated a failure, but using this command it worked for me. Thank you! – mpoletto Aug 24 at 5:38

When you add a third-party repository, you should also add its key to your system. The public key is a string which identifies that certain repository. You can find some more information on this and how to add the key here.

Not the answer you're looking for? Browse other questions tagged or ask your own question.