NOTE: I see many similar topics on this, but I've tried all their suggestions, and nothing has worked. THE MAIN DIFFERENCE SEEMS TO BE: I always get a black screen with a blinking cursor, while others seem to get through the boot-up and see distorted graphics or just their wallpaper.


I do a clean install of Ubuntu 12.10. Boots fine with the “nouveau” graphics driver – graphics (even just menus) are very slow, choppy, and distorted. The three other driver options in Ubuntu (official NVIDIA drivers), all result in a variation of the black screen on boot up. There will be NO access to a command line/GUI in anyway what-so-ever (tried every option recommended out there, but the system is unusable at this stage).

I can only reinstall, and try different drivers…and I only ever get one shot at it.


-Does anyone know of a PROPRIETARY driver that will actually work on 12.10 with a NVIDIA or ATI card?

-Should I just buy a newer graphics card to put in as a replacement?

MORE INFO: This is my second computer, and I’m just trying to get a working install of Ubuntu on it. I don’t want to put much money into it, as I have seen Ubuntu run great on much older/less capable machines. I’ve got a decent'ish Core2Duo Intel processor (2.13Ghz), 2GB of RAM, 320GB hard drive, 32-bit architecture, and there is no other O/S installed. It appears as if the graphics card (NVIDIA Geforce 7350 LE) is holding me back.


-all drivers available in Ubuntu *all fail

-manual install of some different NVIDIA drivers *all fail

-also tried installing the generic kernel, Nvidia driver doesn't work in 12.10 *no difference

-tried installing 12.04 *same results

-every method suggested to at least get a command line after switching to a NVIDIA driver *all fail


Re-tried everything above with a new NVIDIA Geforce 210...same results for everything.


Re-tried everything above with a new AMD Radeon HD 6450...installed the proprietary driver from Ubuntu's "Software Sources" menu...EVERYTHING NOW WORKS. See "answer" below for summary.

  • Why not try 12.04 instead? It's not like you have the latest hardware that only works with a recent kernel version. It might work better for you. – mikewhatever Oct 27 '12 at 5:43
  • I guess by "manually" you mean downloading a driver from the nVidia-site and installing it via a tty? If not you should try that. But getting rid of the Nouveau-drivers is necessary for that. – Mrokii Oct 27 '12 at 10:46
  • Also, getting the driver from nVidia directly has the advantage that you can check which cards it actually supports. – Mrokii Oct 27 '12 at 10:52
  • ***Thank you for the suggestions. I have tried 12.04, exact same results (I will update this in my post). Yes, that is what I meant by "manually", and each driver I got directly from NVIDIA said it supports my specific card...obviously not though. – DS13 Oct 27 '12 at 15:33
  • i dont exactly know its implimentation...but ive heard about bumblebee...some software for pcs wth nvidia grafix – Nirmik Oct 28 '12 at 19:14

Install the linux sources and headers. These are required to build the driver.

sudo apt-get install linux-source linux-headers-3.5.0-17-generic

Then unistall any nvidia drivers you have installed. Then reinstall the nvidia driver

sudo apt-get install nvidia-current

Then restart the computer

sudo shutdown -r now

It should now boot up using the nvidia drivers.

  • Thanks for your input, although as stated (and linked to the topic) in the original post, I tried this with two different NVIDIA cards and the results were exactly the same (unable to boot / black screen with blinking cursor). To explain further, I tried this 6 times in total - 2 NVIDIA cards x 3 drivers each (all after clean installs). *NOTE: This solution will not work for everyone. – DS13 Nov 3 '12 at 18:39

Note: This issue has been resolved by way of a hardware replacement, a solution (in regards to software) was not reached. This answer is intended to save people (with similar circumstances) time. On my system, and being fairly new to Linux...I could not get any NVIDIA drivers to work, after trying two different cards.

The solution for me was an AMD card, with the AMD/ATI proprietary drivers (all versions available in Ubuntu work). For those interested - the open source driver worked, but there were odd colored pixels everywhere.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.