2

I'm trying to set up printing to a networked LPR printer, but I can't seem to make it work. The connexion information that IT gives is:

Print Spooler: printing.domain.edu

Printer Name: PrinterName

Print port: 515

Bidirectional: Disabled

It's an HP LaserJet p4015x, and I'm using the "HP LaserJet p4015x, hpcups 3.10.6 (color, 2-sided printing)" driver, according to CUPS. I have tried installing via the CUPS admin interface as lpd://printing.domain.edu:515/PrinterName, lpd://printing.domain.edu/PrinterName, and http://printing.domain.edu:515/PrinterName, and none of these has worked (i.e. test pages show up as "stopped").

  • lpd:// sounds right (515 is the default port so it should work with or without it). Try telnet printing.domain.edu 515, just to see if it's a firewall blocking you. If you get a connection, type Ctrl+] then Ctrl+D to exit telnet. Also, look for error messages from Cups in /var/log/cups/error_log. – Gilles 'SO- stop being evil' Jan 9 '11 at 16:06
  • Thanks for the help! The telnet connexion worked fine, so I figured it was probably a driver error, and indeed the log was complaining that the hpcups filter didn't exist. Even after I installed the hplips and hplips-cups packages, though, neither of the two drivers (hpijs and hpcups) in the CUPS install database actually worked. However, there was a PPD file in /usr/share/ppd/HP that does work. [I also discovered, via telnet, that the 'printing' subdomain is actually an alias for 'coruscant.domain.edu', which made me happy...] – AVB Jan 9 '11 at 21:59
  • This question seems abandoned, there is not further information or activity added to it for several months. I am flagging this to be closed by a moderator. If you think this issue is still affecting you you can flag a moderator to re-open it. – Bruno Pereira Feb 3 '12 at 1:33

Browse other questions tagged or ask your own question.