Recently decided to switch back to Ubuntu. I have a 3TB drive which was running win7. I had 3 partitions. c: for windows d: data e: data

Have installed ubuntu before so 'thought' I knew what I was doing.

I using netbootin I installed from a usb stick. I didn't choose the default options but I didn't choose the 'manual install' either. I can't remember what option I took but I figured at some stage it would tell me how it was going to partition the disk and at that stage I would see if it had recognised the NTFS partitions and I would be able to abort if it didn't.

Unfortunately, it didn't and just went ahead and installed Ubuntu and made up it's own mind on how it was going to partition the disk. Usual story, the two NTFS data partitions weren't backed up.

Is there anything I can do to retrieve the ntfs data? I'm currently trying out testdisk and I know I can use photodisk to retrieve certain file types but all the filenames will be lost and it's going to take a hell of a lot of time to rename them all.

Any help or assistance would be more than gratefully accepted. Thanks in advance, Niall


1 Answer 1


There is a utility named ntfsundelete which recovers data on NTFS drives. Install it using terminal

sudo apt-get install ntfsprogs

Check out which are your NTFS drives.

sudo fdisk -l

It will provide you detail with partitions and file systems. Note down your NTFS partitions like /dev/sda3 and /dev/sda4.

sudo ntfsundelete /dev/sdaX

where X depends your NTFS partition. it will show your list of recoverable files. You can recover.The names of files that can recovered show up in the far right column. The percentage in the third column tells us how much of that file can be recovered.

enter image description here

For example To quickly recover the PNGs, we will use the * wildcard to recover all of the files that end with .png. Open up the terminal window, enter:

sudo ntfsundelete /dev/sda1 –u –m *.png

For more detail you can visit here.

  • Thanks or the suggestion but I'm afraid it didn't work. When I run the sudo fdisk -l I get Device Boot Start End Blocks Id System /dev/sdb1 1 4294967295 2147483647+ ee GPT when I run ntfsundelete /dev/sdbX I get ubuntu@ubuntu:~$ sudo ntfsundelete /dev/sdb1 NTFS signature is missing. Failed to mount '/dev/sdb1': Invalid argument The device '/dev/sdb1' doesn't have a valid NTFS. Maybe you selected the wrong device? Or the whole disk instead of a partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around? Sorry for the poor layout
    – Niall C
    Oct 26, 2012 at 11:39
  • It cannot locate such package as ntfsprogs, however it is installed in Ubuntu out-of-the-box
    – Suncatcher
    May 26, 2018 at 17:41

Not the answer you're looking for? Browse other questions tagged .