I've installed the latest catalyst driver (beta) following the step in this guide for Ubuntu Quantal Quetzal.
My system is 64 bit and my graphic card is an ATI RadeonHD 6670, this g.c. is Officially Supported (Catalyst & Open Source), you can confirm that from this AMD Linux Community thread.

I don't have any problem, except the AMD testing use only watermark. I see the following frame in any stage into the OS (logged, unlloged, etc.) except in the terminals.


I found different versions of how to remove this image, but this change according to the system, so I want an answer from this popular (trusted) site.

  • How to solve this issue in Ubuntu 12.10 32b?
  • This procedure is different in a 64b system?

10 Answers 10


The script above did not work for me. However I found a much simpler answer here

Edit the ati signature file:

sudo gedit /etc/ati/signature

and just replace the "UNSIGNED" line with the following code


It worked fine for me.

The resulting file should be 238 bytes long for it to work.

  • 6
    This fix didn't work for me at first, then I realized I added a trailing space at the end of the line, and a newline at the end of the file. Be sure the file has ONLY a single line with the signature and NO whitespace for it to work.
    – Tobias J
    Mar 23, 2013 at 18:05

For Ubuntu 12.10 64-bits

I fixed it using the following script. Found At: http://ubuntuforums.org/showthread.php?t=2076381

Under Ubuntu 12.10 x64 and driver AMD 12.11 beta.

echo "Come on AMD!"
echo "Removing AMD logo from "$DRIVER
for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
    sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
echo "Reboot computer to finish"

Copy and paste the code from above into a new file, save it, and do sudo bash filename in the terminal.

  • Your system is the same that mine (software). So it should work. The problem is that I need to be member of the Ubuntu Forums to download the file. Could you past the code here or in Paste Ubuntu and link it?
    – Lucio
    Oct 30, 2012 at 0:28
  • This is the direct download(of course use at own risk): paste.ubuntu.com/1322981 Nov 1, 2012 at 9:25
  • Please tell me how did you launch the file. I saved the code in a file, but I can't launch it with the sudo ./file command.
    – Lucio
    Nov 3, 2012 at 19:23
  • 1
    @Lucio: You need to mark the file executable to launch it that way. Use chmod +x file to set the executable flag. Alternatively, just launch it with sudo bash file. Also, I feel compelled to point out that that script does exactly the same hackery as the one I pointed to. Nov 4, 2012 at 3:55
  • 1
    This script no longer appears to work with version 13.3 beta drivers. /usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so is no longer present. Mar 23, 2013 at 1:07

For Ubuntu 11.04

I found this elsewhere on the net and I ran it on a Ubuntu 11.04 - it works great!


Put this in a text file and save it (call it fixwatermark.sh):

for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER

With terminal go to the location where you saved it and do a

chmod +x fixwatermark.sh

to make it executable and a

sudo ./fixwatermark.sh

to let the script remove the enableLogo

  • It worked for me on 13.04 but I had to reboot.
    – Étienne
    Nov 5, 2013 at 23:30

The correct solution has been published on the unoffiical wiki page for AMD GPU Linux drivers. The signatures for the latest GPUs are available only in the latest drivers. When using an old driver, there are no signatures for the newer GPU present in the computer. The solution, as given in the wiki, is to simply copy the control file of the latest driver and put them in your computer's ATI driver directory.

Here is what you do: Download the latest driver, extract it, copy the etc/ati/control file, and overwrite the /etc/ati/control file. The steps to follow are as follows:

$ cd ~ 
$ mkdir amd-gpu-driver 
$ cd amd-gpu-driver/ 
$ wget http:amd-website-linux-gpu-driver-url-amd-driver.zip 
$ tar -xvf amd-driver.zip 
$ sh amd-driver.run --extract driver 
$ sudo mv /etc/ati/control ./control.bak 
$ sudo cp driver/common/etc/ati/control /etc/ati 

Please replace the URLs and filenames appropriately.

  • this is the real solution patching logo calls from fglrx_drv.so -as described in above answers- only hide the watermark but you still have an "unsupported board" so aticonfig is unusable because "No supported adapters detected" Jan 9, 2015 at 0:20

For Ubuntu 12.10 64-bits

Running this script worked for me on Ubuntu 12.10 64bit:

for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER

One way to accomplish this:

  1. Open a terminal
  2. Type 'nano'
  3. Paste the above code in to the editor
  4. Control-x, Y to save
  5. Enter a filename (I used 'logo.sh') and enter to return to the command line
  6. chmod a+x logo.sh to make the script executable
  7. sudo ./logo.sh
  8. sudo reboot

No more logo after reboot for me.


I think this is caused by the modaliases that gets your pc to recognise your hardware.

When I have previously removed the ATI catayst application I have had to reinstall the fglrx-modaliases so that it can be installable through the additional drivers at a later stage.

So I would open a terminal up and enter

sudo apt-get remove fglrx-modaliases

This should not remove fglrx but just the modaliases

If there are problems after this obviously reinstall the modaliases

sudo apt-get install fglrx-modaliases
  • I get a Virtual packages like 'fglrx-modaliases' can't be removed after issueing the sudo apt-get remove fglrx-modaliases.
    – Rinzwind
    Sep 10, 2011 at 9:52

edit: sorry I missed the signature answer but did not want to keep this from people.

Get a copy of the control file from a release that does work for you and write it over (you can extract the file from the tar.gz with fileroller)..


A reboot suffices.

Example from ...


enter image description here

enter image description here

Worked for me on 12.04, 12.10 and 13.04.

  • It worked for what? What does your method does? I'm missing the point here..
    – Lucio
    Apr 27, 2013 at 20:07
  • 1
    simple: you extract the file named "control" from the driver tar file version that did once did work and copy it over the one you are using now. After a reboot the image "AMD unsupported hardware" is gone.
    – Rinzwind
    Apr 27, 2013 at 20:26

For Ubuntu 13.04 64-bits

Since the latest drivers (13.4 and greater, not 12.11 beta as is in the question) the application will automatically remove the "AMD Testing Use Only" watermark during installation.

More about, including installation instructions: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx

  • I'm not voting since I can't test. I'm depending on community and comments to make it happen one way or the other. Jul 15, 2013 at 22:28
  • It appears to be removed from the just released 13.8 beta drivers. 13.6 still had it displaying (source: support.amd.com/us/kbarticles/Pages/…)
    – user1614
    Aug 7, 2013 at 2:24

I had the same problem, and also another one that you seem to also have at the same time: not knowing how to install the right AMD Radeon HD 6450 driver. As a consequence, when I tried to install Ubuntu 10.10, it froze just after the login screen and when I tried to install Ubuntu 11.10, it did not even arrive to the login screen.

Here is what I did, which solved the problem:

  • using another computer, download the latest proprietary driver from ATI on the official site. In my case I had to download it from here.
  • put the driver on a USB key
  • reboot the computer we want to repair
  • in the grub menu, select the recovery mode. This results in arriving at a command line interface. This is a proof that the Ubuntu operating system is functioning but that the problem is indeed the graphical card.
  • uninstall all previous versions of flgrx by launching sudo apt-get remove flgrx for example
  • mount the USB key with something close to mkdir /mnt/usb followed by sudo mount /dev/sdb /mnt/usb. Another way for this little step is explained here.
  • use the cd command to place yourself in the folder where the downloaded driver is
  • if necessary, make the driver be executable with something like chmod +x ./ati-driver-installer-11-11-x86.x86_64.run
  • execute the driver using sudo ./ati-driver-installer-11-11-x86.x86_64.run
  • follow the instructions given on the installer
  • if this step did not work, you may want to try sudo ./ati-driver-installer-11-11-x86.x86_64.run --force instead
  • reboot your computer

Then your two problems should both be solved!


According to the Arch Wiki's Catalyst page, the following script should do it. It's a bit hackish.

for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
 sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER

Since that script is for Arch, you may need to play with bits of it; for example, Ubuntu may have fglrx_drv.so in a different location. Be prepared to reinstall the driver from the command line if this doesn't work.

  • I don't want to play with it and see whats happens. I hope that someone that know exactly what do should I do, without destabilizing the system. Also, I have the glrx_drv.so file in this path: /etc/alternatives/x86_64-linux-gnu_xorg_extra_modules/modules/drivers
    – Lucio
    Oct 26, 2012 at 15:36
  • This does seem to be the most commonly accepted solution, and I haven't seen anyone complaining that it didn't work. When I said "play with it" I mainly meant the path to the .so; clearly a little modification is necessary in your case ^_^ Oct 27, 2012 at 1:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.