I would like to install chrome autosave plugin on ubuntu. when I try to install it with these steps https://github.com/NV/chrome-devtools-autosave-server , I got some errors...

there was not installed node and npm out of box on ubuntu 12.10. So I installed npm and node with these commands.

sudo apt-get install npm
sudo apt-get install node

and I tried to install autosave

here is the output:

sudo npm install -g autosave
npm http GET https://registry.npmjs.org/autosave
npm http 304 https://registry.npmjs.org/autosave
npm http GET https://registry.npmjs.org/commander
npm http 304 https://registry.npmjs.org/commander
/usr/local/bin/autosave -> /usr/local/lib/node_modules/autosave/bin/autosave

> autosave@1.0.2 install /usr/local/lib/node_modules/autosave
> node ./scripts/install.js

npm ERR! error installing autosave@1.0.2
npm WARN This failure might be due to the use of legacy binary "node" 
npm WARN For further explanations, please read
npm WARN /usr/share/doc/nodejs/README.Debian
npm WARN 

npm ERR! autosave@1.0.2 install: `node ./scripts/install.js`
npm ERR! `sh "-c" "node ./scripts/install.js"` failed with 1
npm ERR! 
npm ERR! Failed at the autosave@1.0.2 install script.
npm ERR! This is most likely a problem with the autosave package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node ./scripts/install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls autosave
npm ERR! There is likely additional logging output above.
npm ERR! 
npm ERR! System Linux 3.5.0-17-generic
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "autosave"
npm ERR! cwd /home/naczu
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! message autosave@1.0.2 install: `node ./scripts/install.js`
npm ERR! message `sh "-c" "node ./scripts/install.js"` failed with 1
npm ERR! errno {}
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/naczu/npm-debug.log
npm not ok

and here is README.debian

nodejs for Debian

packaged modules

The global search path for modules is

Future packages of node modules will use that directory,
so it should be used wisely.

user modules

Node looks for modules in ./node_modules directory first;
please read node#modules documentation carefully for more information.

Node does not look for modules in /usr/local/lib/node_modules,
where npm put them.
Please read npm-link(1) of npm package, to understand how to properly
use npm-installed modules in a project.

Note that require.paths is not supported in future node versions.
See also node(1) for more information about NODE_PATH.

nodejs command

The upstream name for the Node.js interpreter command is "node".
In Debian the interpreter command has been changed to "nodejs".

This was done to prevent a namespace collision: other commands use
the same name in their upstreams, such as ax25-node from the "node"

Scripts calling Node.js as a shell command must be changed to instead
use the "nodejs" command.

ok I have solved my problem. I found a better extension. that is Tincr. you can edit and autosave js and css files on chrome dev tools. that is absolutely so useful. here is the link. maybe some people need this as I need. click here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.