0

I've just installed Ubuntu 12.10 and I'm trying to use the Magic Mouse but it doesn't work properly, the problem is that the tracking is too much sensitive and the scroll is too much insensitive.

I tried to edit settings with the xinput set-ptr-feedback command but nothing changed.

Is there anyone with the same problem who can help me?

UPDATE: Problem solved for the tracking, but scrolling is still too slow, this is my xinput setting for the mouse:

luca@luca-iMac:~$ xinput list-props 14

Device 'Magic Mouse':

    Device Enabled (146):   1
    Coordinate Transformation Matrix (148): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (273): 0
    Device Accel Constant Deceleration (274):   3.000000
    Device Accel Adaptive Deceleration (275):   1.000000
    Device Accel Velocity Scaling (276):    10.000000
    Device Product ID (265):    1452, 781
    Device Node (266):  "/dev/input/event10"
    Evdev Axis Inversion (277): 0, 0
    Evdev Axes Swap (279):  0
    Axis Labels (280):  "Rel X" (156), "Rel Y" (157), "Rel Horiz Wheel" (271), "Rel Vert Wheel" (272)
    Button Labels (281):    "Button Left" (149), "Button Middle" (150), "Button Right" (151), "Button Wheel Up" (152), "Button Wheel Down" (153), "Button Horiz Wheel Left" (154), "Button Horiz Wheel Right" (155)
    Evdev Middle Button Emulation (282):    0
    Evdev Middle Button Timeout (283):  50
    Evdev Third Button Emulation (284): 0
    Evdev Third Button Emulation Timeout (285): 1000
    Evdev Third Button Emulation Button (286):  3
    Evdev Third Button Emulation Threshold (287):   20
    Evdev Wheel Emulation (288):    0
    Evdev Wheel Emulation Axes (289):   0, 0, 4, 5
    Evdev Wheel Emulation Inertia (290):    10
    Evdev Wheel Emulation Timeout (291):    0
    Evdev Wheel Emulation Button (292): 4
    Evdev Drag Lock Buttons (293):  0

Any idea?

5

This works for me in 12.10 for speeding up the scrolling.

sudo rmmod hid_magicmouse
modprobe hid_magicmouse scroll-speed=55 scroll-acceleration=1

You can play around with the speed. The min is 0 and the max is 63 (default is 32 I believe). Anything over 50 feels 'natural' to me. I used scroll-acceleration of 1; which feels like enough (when you move fast, scrolling is exponential).

If you dont' type them in right, the mouse will not be able to work until valid settings are applied.

  • This is for scroll not for movement, the problem asket here is about the cursor moves too fast – Albert Català Mar 18 '16 at 16:05
  • 1
    Note that after running rmmod, the mouse will completely stop working until deleting and re-pairing with bluetooth (at least in 17.04/zesty) – ijoseph Jun 23 '17 at 17:23
2

I believe I did something like this to fix a similar problem http://numberformatdata.wordpress.com/2011/05/08/apple-magic-mouse-works-with-ubuntu/

More detailed explanation: http://patrickmylund.com/blog/lowering-gaming-mouse-sensitivity-in-ubuntu-9-10/

I think these directions will still work on 12.10

  • Thanks for the tip, it worked fine for the tracking, but the scrolling is still too slow. – L. Catallo Oct 26 '12 at 13:35
  • I have tried changing these settings on Ubuntu 12.04. And they do change, but I don't see any change in tracking speed, even when setting "Device Accel Constant Deceleration" to 20. Is there any trick to this that I'm missing? – Eduard Grebe Nov 1 '12 at 9:42
1

The directions linked by Will Huang worked for me on 12.10. I just setup the following aliases in ~/.bash_aliases

alias mouse-list='xinput --list-props "bluetooth mouse"' 
alias mouse-slow='xinput --set-prop "bluetooth mouse" "Device Accel Constant Deceleration" 1.5'

http://numberformatdata.wordpress.com/2011/05/08/apple-magic-mouse-works-with-ubuntu/

0

In Ubuntu 14.04 I ended up with:

sudo rmmod hid_magicmouse
sudo modprobe hid_magicmouse scroll-speed=50 scroll-acceleration=1
xinput --set-prop "Elijah's mouse" "Device Accel Constant Deceleration" 5

The variable in xinput --set-prop can be found by doing a xinput --list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.